【PAT甲级A1060】Are They Equal (25分)(c++)

1060 Are They Equal (25分)

作者:CHEN, Yue
单位:浙江大学
代码长度限制:16 KB
时间限制:400 ms
内存限制:64 MB

If a machine can save only 3 significant digits, the float numbers 12300 and 12358.9 are considered equal since they are both saved as 0.123×10^​5​​ with simple chopping. Now given the number of significant digits on a machine and two float numbers, you are supposed to tell if they are treated equal in that machine.

Input Specification:
Each input file contains one test case which gives three numbers N, A and B, where N (<100) is the number of significant digits, and A and B are the two float numbers to be compared. Each float number is non-negative, no greater than 10​100​​ , and that its total digit number is less than 100.

Output Specification:
For each test case, print in a line YES if the two numbers are treated equal, and then the number in the standard form 0.d[1]…d[N]*10^k (d[1]>0 unless the number is 0); or NO if they are not treated equal, and then the two numbers in their standard form. All the terms must be separated by a space, with no extra space at the end of a line.

Note: Simple chopping is assumed without rounding.

Sample Input 1:

3 12300 12358.9

Sample Output 1:

YES 0.123*10^5

Sample Input 2:

3 120 128

Sample Output 2:

NO 0.120*10^3 0.128*10^3

题意:

将输入的两个非负浮点数在指定有效数字规定下,用题中所述的标准形式表示,判断两数用这种形式表达出来的式子是否相同。

思路:

  • 由于数字很大,以字符串读入;
  • 首先删除字符串的前导零;
  • 如果此时字符串为空,说明这个数时零。
  • 如果此时字符串的首位为小数点‘.’,去掉小数点,并继续删除零,此时每删除一个,指数-1。若不是则寻找小数点,指数等于小数点的位置,删除小数点(若没找到,指数等于字符串长度)。
  • 然后将字符串控制到有效长度,若不足,需要在字符串后补零。

参考代码:

#include <iostream>
#include <string>
using namespace std;
int n;
string deal(string str,int &e)
{
	while(str.length()>0&&str[0]=='0'){
		str.erase(str.begin());
	}
	if(str[0]=='.'){
		str.erase(str.begin());
		while(str.length()>0&&str[0]=='0'){
			str.erase(str.begin());
			e--;
		}
	}else if(str.find('.')!=string::npos){
		e+=str.find('.');
		str.erase(str.begin()+e);
	}
	else e+=str.length();
	if(str.length()==0) e=0;
	int num(0),k(0);
	string res;
	while(num<n){
		if(k<str.length())res+=str[k++];
		else res+='0';
		num++;
	}
	return res;
}
int main(){
	int e1(0),e2(0);
	string str1,str2,str3,str4;
	cin>>n>>str1>>str2;
	str3=deal(str1,e1);
	str4=deal(str2,e2);
	if(str3==str4&&e1==e2){
		cout<<"YES 0."<<str3<<"*10^"<<e1<<endl;
	}
	else
		cout<<"NO 0."<<str3<<"*10^"<<e1<<" 0."<<str4<<"*10^"<<e2<<endl;
	return 0;
} 

如有错误,欢迎指正

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值