【PAT甲级A1096】 Consecutive Factors (20分)(c++)

1096 Consecutive Factors (20分)

作者:CHEN, Yue
单位:浙江大学
代码长度限制:16 KB
时间限制:400 ms
内存限制:64 MB

Among all the factors of a positive integer N, there may exist several consecutive numbers. For example, 630 can be factored as 3×5×6×7, where 5, 6, and 7 are the three consecutive numbers. Now given any positive N, you are supposed to find the maximum number of consecutive factors, and list the smallest sequence of the consecutive factors.

Input Specification:
Each input file contains one test case, which gives the integer N (1<N<23​​1 ).

Output Specification:
For each test case, print in the first line the maximum number of consecutive factors. Then in the second line, print the smallest sequence of the consecutive factors in the format factor[1]*factor[2]*...*factor[k], where the factors are listed in increasing order, and 1 is NOT included.

Sample Input:

630

Sample Output:

3
5*6*7

题意:

输出一个整数的最长连续因数,若长度相等,输出最小的。

思路:

从2开始遍历,23…直到输入的数不能整除为止,再进行34…,过程中统计长度,其中因数的个数肯定小于sqrt(n)+1,如sqrt(30)+1=6.47,不存在两个大于6的连续整数是30的因子。(注意:素数的只有1和自己本身会被整数,需要被单独拎出来)。

参考代码:

#include <iostream>
#include <cmath>

using namespace std;

int main() {
    int n, maxlen = 0, st = 0;
    scanf("%d", &n);
    for (int i = 2; i <= sqrt(n); i++) {
        long long temp = 1, j;
        for (j = i; j <= sqrt(n) + 1; j++) {
            temp *= j;
            if (n % temp != 0)break;
        }
        if (j - i > maxlen) {
            maxlen = j - i;
            st = i;
        }
    }
    if (st == 0)printf("1\n%d", n);
    else {
        printf("%d\n", maxlen);
        for (int i = 0; i < maxlen; i++) {
            if (i != 0)printf("*");
            printf("%d", st + i);
        }
    }
    return 0;
}

如有错误,欢迎指正

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值