1096 Consecutive Factors (20分)--PAT甲级真题

Among all the factors of a positive integer N, there may exist several consecutive numbers. For example, 630 can be factored as 3×5×6×7, where 5, 6, and 7 are the three consecutive numbers. Now given any positive N, you are supposed to find the maximum number of consecutive factors, and list the smallest sequence of the consecutive factors.

Input Specification:
Each input file contains one test case, which gives the integer N (1<N<2​31).

Output Specification:
For each test case, print in the first line the maximum number of consecutive factors. Then in the second line, print the smallest sequence of the consecutive factors in the format factor[1] * factor[2]*…*factor[k], where the factors are listed in increasing order, and 1 is NOT included.

Sample Input:

630

Sample Output:

3
5*6*7

题目大意:找出正整数N的最长的连续子因素,如果有多个,输出最小的那个;如果N是素数,则输出N;

分析:这道题目暴力可解,但是也不能太暴力,还是有些技巧的;连续最长因素序列开始的数字肯定小于sqrt(N)+1;因为(sqrt(N)+1)*(sqrt(N)+2)>N;因此只要去看看以i(2<=i<=sqrt(N)+1)为开头的因素序列,最长可以为多长,找出其中最长的,就是答案;

#include<iostream> 
#include<cmath>
using namespace std; 
int main(){
	int n;
	scanf("%d", &n);
	int e = sqrt(n) + 1;
	int first = 0, L = 0;
	for (int i = 2; i <= e; i++) {
		int m = 1;
		for (int j = 0; j <= 12; j++) {
			m *= i + j;
			if (n%m != 0) {
				if (j > L) {
					L = j;
					first = i; 
				}
				break;
			}
		}
	}
	if (L == 0)
		printf("1\n%d", n);
	else {
		printf("%d\n", L);
		for (int i = 0; i < L; i++) {
			if (i != 0)
				printf("*");
		    printf("%d", first + i);
		}
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值