A1096 Consecutive Factors (20 分)(求N能被连续整数乘积整除的最多个数)

Among all the factors of a positive integer N, there may exist several consecutive numbers. For example, 630 can be factored as 3×5×6×7, where 5, 6, and 7 are the three consecutive numbers. Now given any positive N, you are supposed to find the maximum number of consecutive factors, and list the smallest sequence of the consecutive factors.

Input Specification:

Each input file contains one test case, which gives the integer N (1<N<2^​31​​).

Output Specification:

For each test case, print in the first line the maximum number of consecutive factors. Then in the second line, print the smallest sequence of the consecutive factors in the format factor[1]*factor[2]*...*factor[k], where the factors are listed in increasing order, and 1 is NOT included.

Sample Input:

630

Sample Output:

3
5*6*7

题意:

给出一个正整数N(1<N<2^​31​​),求一段连续的整数,使得N能够被这段连续整数的乘积整除。如果有多个方案,输出连续整数个数最多的方案;如果还有多种方案,输出其中第一个数最小的方案。

思路:

本题的思路比较难想,想要找到连续整数最多的那一个,就设变量连续整数长度ansLen和对应的第一个整数ansI,枚举数字,判断是否满足情况,不断更新这两个值。

值得注意的是,N 不会被除自己以外的大于sqrt(N) 的整数整除,因此要从 2~ sqrt(N) 遍历连续整数的第一个。

如果遍历结束后,ansLen == 0, 那么说明不超过sqrt(N)不存在连续的整数,因此答案就是N本身

注意:

  1. 需要用long long ,防止中间成绩超过 int 导致溢出

#include <cstdio>
#include <cmath>
#include <algorithm>
typedef long long ll;
int main(){
  ll n;
  scanf("%lld", &n);
  ll sqr = (ll)sqrt(1.0 * n), ansI = 0, ansLen = 0;
  for(ll i = 2; i <= sqr; i++){   //在2~sqrt(n)中枚举序列的第一个整数
    ll temp = 1, j = i;
    while(1){
      temp *= j;
      if(n % temp != 0)   //寻找满足条件的连续序列
        break;
      if(j - i + 1 > ansLen){
        ansI = i;
        ansLen = j - i + 1;
      }
      j++;    //j不断增大,序列中最后一个
    }
  }
  if(ansLen == 0){
    printf("1\n%lld", n);
  }
  else{
    printf("%lld\n", ansLen);
    for(ll i = 0; i < ansLen; i++){
      printf("%lld", ansI + i);
      if(i < ansLen - 1){
        printf("*");
      }
    }
  }
  return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值