The Triangle
-
描述
-
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5
(Figure 1)
Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.-
输入
- Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99. 输出
- Your program is to write to standard output. The highest sum is written as an integer. 样例输入
-
5 7 3 8 8 1 0 2 7 4 4 4 5 2 6 5
样例输出
-
30
想法:
简单动态规划;从a【1】【1】开始,a【i】【j】=a【i】【j】+max(a【i-1】【j】,a【i-1】【j-1】)这样扩张保留最大数和。
代码:
#include<stdio.h>
#include<string.h>
int a[200][200];
int max(int x,int y)
{
return x>y?x:y;
}
int main()
{
memset(a,0,sizeof(a));
int n,i,j;
scanf("%d",&n);
for(i=1;i<=n;i++)
{ for(j=1;j<=i;j++)
scanf("%d",&a[i][j]);
}
for(i=1;i<=n;i++)
{
for(j=1;j<=i;j++)
{
a[i][j]=a[i][j]+max(a[i-1][j],a[i-1][j-1]);
}
}
int maxx=-1;
for(j=1;j<=n;j++)
{
if(a[n][j]>maxx) maxx=a[n][j];
}
printf("%d\n",maxx);
return 0;
}