(KMP裸题)hdu1686 Oulipo

 

Problem Description

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.
 

 

 

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.

 

 

Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.
 

 

 

Sample Input

 

3

BAPC

BAPC

AZA

AZAZAZA

VERDI

AVERDXIVYERDIAN

 

 

Sample Output

 

1

3

0

 

 

Source

华东区大学生程序设计邀请赛_热身赛

 

 

Recommend

lcy   |   We have carefully selected several similar problems for you:  1358 1711 3336 3746 2203 

 

哔哩哔哩上大佬写的代码,以后作为模板使用,,,KMP刚开始接触,理解得还不是很透彻,,,

 

后记?!:

如何理解KMP 链接在此,还不点?!这位大佬是我看的多个讲解博客和视频中讲得最清晰的一个(大佬的其他算法的讲解也不错哦)。

//kmp裸题
#include<bits/stdc++.h>


using namespace std;
const int maxn=1e6+10;
int nxt[maxn];  //存储真前缀和真后缀相匹配的最大长度,所谓真前缀,就是长度小于字符串的长度,例如,abcd中最长真前缀是abc,真后缀同理
char str[maxn],mo[maxn];


void getNext(){
    int i=0,j=-1,len=strlen(mo); /*nxt[0]默认为-1,nxt[0]规定为0,
                                 当然也可以理解成j为真前缀和真后缀相匹配的最大长度,
                                 而真前缀长度肯定比字符 */
    nxt[0]=-1;
    while(i<len){
        if(j==-1||mo[i]==mo[j]) nxt[++i]=++j;
        else j=nxt[j];
    }
}


int kmp(){
	getNext();
    int i=0,j=0,len1=strlen(str),len2=strlen(mo);
    int ans=0;
    while(i<len1){
        //cout<<"***j="<<j<<endl;
        if(j==-1||mo[j]==str[i]) i++,j++;
        else j=nxt[j];
        if(j==len2) ans++;
         //cout<<"j="<<j<<endl;
    }
    return ans;
}


int main(){
    int t;
    scanf("%d",&t);
    while(t--){
        scanf("%s%s",mo,str);
        /*for(int i=0;i<=10;i++)
            cout<<nxt[i]<<endl;*/
        printf("%d\n",kmp());
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值