POJ1201[Intervals]

Intervals
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 27184 Accepted: 10434
Description

You are given n closed, integer intervals [ai, bi] and n integers c1, …, cn.
Write a program that:
reads the number of intervals, their end points and integers c1, …, cn from the standard input,
computes the minimal size of a set Z of integers which has at least ci common elements with interval [ai, bi], for each i=1,2,…,n,
writes the answer to the standard output.
Input

The first line of the input contains an integer n (1 <= n <= 50000) – the number of intervals. The following n lines describe the intervals. The (i+1)-th line of the input contains three integers ai, bi and ci separated by single spaces and such that 0 <= ai <= bi <= 50000 and 1 <= ci <= bi - ai+1.
Output

The output contains exactly one integer equal to the minimal size of set Z sharing at least ci elements with interval [ai, bi], for each i=1,2,…,n.
Sample Input

5
3 7 3
8 10 3
6 8 1
1 3 1
10 11 1
Sample Output

6
Source

solution: 差分约束系统+spfa

#include <cstdio>
#include <iostream>
#include <queue>
#include <algorithm>
#include <cstring>
using namespace std;

#define M 50010
#define N M<<2

int nxt[N], to[N], vl[N], head[M];
int dist[N];
bool vis[M];
int cnt = 0;
int MIN, MAX;

void addeage( int u, int v, int w ){
    nxt[++cnt] = head[u], to[cnt] = v, vl[cnt] = w, head[u] = cnt;
}

void SPFA(){
    queue<int> q;
    memset( dist, -0x3f3f3f3f, sizeof(dist));
    memset( vis, false, sizeof(vis));
    while ( !q.empty() ) q.pop();
    q.push(MIN);
    dist[MIN] = 0;
    vis[MIN] = true;
    while ( !q.empty() ){
        int cur = q.front();
        q.pop();
        vis[cur] = false;
        for ( int i = head[cur]; i; i = nxt[i] ){
            int v = to[i];
            if ( dist[v] < dist[cur] + vl[i] ){
                dist[v] = dist[cur] + vl[i];
                if ( !vis[v] ){
                    vis[v] = true;
                    q.push(v);
                }
            }
        }
    }
}

int main(){
    int n;
    scanf( "%d", &n );
    for ( int i = 1; i <= n; i++ ){
        int u, v, w;
        scanf( "%d%d%d", &u, &v, &w );
        addeage( u-1, v, w );
        MIN = min( MIN, u-1);
        MAX = max( MAX, v );
    }
    for ( int i = MIN; i <= MAX; i++){
        addeage( i, i+1, 0);
        addeage( i+1, i, -1);
    }
    SPFA();
    printf( "%d", dist[MAX]);
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值