PAT甲级 1126 Eulerian Path (25)

1126 Eulerian Path (25 分)

In graph theory, an Eulerian path is a path in a graph which visits every edge exactly once. Similarly, an Eulerian circuit is an Eulerian path which starts and ends on the same vertex. They were first discussed by Leonhard Euler while solving the famous Seven Bridges of Konigsberg problem in 1736. It has been proven that connected graphs with all vertices of even degree have an Eulerian circuit, and such graphs are called Eulerian. If there are exactly two vertices of odd degree, all Eulerian paths start at one of them and end at the other. A graph that has an Eulerian path but not an Eulerian circuit is called semi-Eulerian. (Cited from https://en.wikipedia.org/wiki/Eulerian_path)

Given an undirected graph, you are supposed to tell if it is Eulerian, semi-Eulerian, or non-Eulerian.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 2 numbers N (≤ 500), and M, which are the total number of vertices, and the number of edges, respectively. Then M lines follow, each describes an edge by giving the two ends of the edge (the vertices are numbered from 1 to N).

Output Specification:

For each test case, first print in a line the degrees of the vertices in ascending order of their indices. Then in the next line print your conclusion about the graph -- either EulerianSemi-Eulerian, or Non-Eulerian. Note that all the numbers in the first line must be separated by exactly 1 space, and there must be no extra space at the beginning or the end of the line.

Sample Input 1:

7 12
5 7
1 2
1 3
2 3
2 4
3 4
5 2
7 6
6 3
4 5
6 4
5 6

Sample Output 1:

2 4 4 4 4 4 2
Eulerian

Sample Input 2:

6 10
1 2
1 3
2 3
2 4
3 4
5 2
6 3
4 5
6 4
5 6

Sample Output 2:

2 4 4 4 3 3
Semi-Eulerian

Sample Input 3:

5 8
1 2
2 5
5 4
4 1
1 3
3 2
3 4
5 3

Sample Output 3:

3 3 4 3 3
Non-Eulerian

 欧拉回路的定义是一笔可以走过样例所给的边一次,不能重复,并且回到原点,而半欧拉图是经过每条边一次但是不回到原点,剩下的情况就不是欧拉图了。其实题目已经说明了如何判断欧拉回路和半欧拉图了,就是看度数,全是偶数就是欧拉回路,有两个奇数是半欧拉图,那么只要判断样例所给的点是否是连通的就行,不能存在孤立的点。

#include<iostream>
#include<algorithm>
#include<stack>
#include<string>
#include<set>
#include<vector>
#include<unordered_map>
#include<unordered_set>
#include<math.h>
#include<map>
#include<queue>
#include<cstring>
using namespace std;

const int maxn=510;
int n,m,deg[maxn],vis[maxn];
vector<int> v[maxn];
int cnt=0;

void dfs(int x){
	vis[x]=1;
	cnt++;
	for(int i=0;i<v[x].size();i++){
		if(vis[v[x][i]]==0) dfs(v[x][i]);
	}
}

int main(){
	int a,b;
	scanf("%d%d",&n,&m);
	for(int i=0;i<m;i++){
		scanf("%d%d",&a,&b);
		v[a].push_back(b);
		v[b].push_back(a);
		deg[a]++;
		deg[b]++;
	}
	dfs(1);
	int odd=0;
	for(int i=1;i<=n;i++){
		printf("%d%c",deg[i],i==n?'\n':' ');
		if(deg[i]%2!=0) odd++;
	}
	if(odd==2&&cnt==n) printf("Semi-Eulerian\n");
	else if(odd==0&&cnt==n) printf("Eulerian\n");
	else printf("Non-Eulerian\n");

	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值