1126 Eulerian Path (25 分)--PAT甲级

给定一个无向图,判断该图是否为欧拉图、半欧拉图或非欧拉图。欧拉图所有顶点度数为偶数,半欧拉图有两个顶点度数为奇数,其余为偶数。输入包含顶点数、边数及边的连接信息,输出各顶点度数及结论。
摘要由CSDN通过智能技术生成

1126 Eulerian Path (25 分)

In graph theory, an Eulerian path is a path in a graph which visits every edge exactly once. Similarly, an Eulerian circuit is an Eulerian path which starts and ends on the same vertex. They were first discussed by Leonhard Euler while solving the famous Seven Bridges of Konigsberg problem in 1736. It has been proven that connected graphs with all vertices of even degree have an Eulerian circuit, and such graphs are called Eulerian. If there are exactly two vertices of odd degree, all Eulerian paths start at one of them and end at the other. A graph that has an Eulerian path but not an Eulerian circuit is called semi-Eulerian. (Cited from https://en.wikipedia.org/wiki/Eulerian_path)

Given an undirected graph, you are supposed to tell if it is Eulerian, semi-Eulerian, or non-Eulerian.
Input Specification:

Each input file contains one test case. Each case starts with a line containing 2 numbers N (≤ 500), and M, which are the total number of vertices, and the number of edges, respectively. Then M lines follow, each describes an edge by giving the two ends of the edge (the vertices are numbered from 1 to N).
Output Specification:

For each test case, first print in a line the degrees of the vertices in ascending order of their indices. Then in the next line print your conclusion about the graph – either Eulerian, Semi-Eulerian, or Non-Eulerian. Note that all the numbers in the first line must be separated by exactly 1 space, and there must be no extra space at the beginning or the end of the line.
Sample Input 1:

7 12
5 7
1 2
1 3
2 3
2 4
3 4
5 2
7 6
6 3
4 5
6 4
5 6

Sample Output 1:

2 4 4 4 4 4 2
Eulerian

Sample Input 2:

6 10
1 2
1 3
2 3
2 4
3 4
5 2
6 3
4 5
6 4
5 6

Sample Output 2:

2 4 4 4 3 3
Semi-Eulerian

Sample Input 3:

5 8
1 2
2 5
5 4
4 1
1 3
3 2
3 4
5 3

Sample Output 3:

3 3 4 3 3
Non-Eulerian

题目大意:判断一个图是欧拉图、半欧拉图还是非欧拉图。欧拉图是存在一条欧拉回路,即一个连通图中所有顶点的度为偶数;半欧拉图是存在一条欧拉路径,即连通图中只有两个顶点的度为奇数,其余均为偶数。
思路:计算所有顶点的度并输出,注意需要先判断连通性,否则一个5分的测试点通不过。

c++代码

#include <iostream>
#include<cstdio>
#include<cstring>
#include <algorithm>
#include<vector>
using namespace std;
const int maxn = 510;
bool visit[maxn];
int n;
int c=0;
vector<vector<int> > node;
void dfs(int root){
    visit[root]=true;
    c++;
    for(int j=0;j<node[root].size();j++){
        if(visit[node[root][j]]==false) dfs(node[root][j]);
    }
}

int main()
{
    int m;
    scanf("%d %d",&n,&m);
    node.resize(n+1);
    for(int i=0;i<m;i++){
        int a,b;
        scanf("%d %d",&a,&b);
        node[a].push_back(b);
        node[b].push_back(a);
    }
    int cnt=0;
    bool is=true;
    for(int i=1;i<=n;i++){
        if(node[i].size()%2==1) cnt++;
        if (i==1) printf("%d",node[i].size());
        else printf(" %d",node[i].size());
    }
    printf("\n");
    dfs(1);
    if(c==n && cnt==0) printf("Eulerian\n");
    else if(c==n && cnt==2) printf("Semi-Eulerian\n");
    else printf("Non-Eulerian\n");
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值