Ignatius’s puzzle
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7082 Accepted Submission(s): 4891
Problem Description
Ignatius is poor at math,he falls across a puzzle problem,so he has no choice but to appeal to Eddy. this problem describes that:f(x)=5*x^13+13*x^5+k*a*x,input a nonegative integer k(k<10000),to find the minimal nonegative integer a,make the arbitrary integer x ,65|f(x) if
no exists that a,then print “no”.
Input
The input contains several test cases. Each test case consists of a nonegative integer k, More details in the Sample Input.
Output
The output contains a string “no”,if you can’t find a,or you should output a line contains the a.More details in the Sample Output.
Sample Input
11
100
9999
Sample Output
22
no
43
思路:关键在 对于任意的x都有 65 | f(x) .即 f(x) 可以整除65
所以我们可以取一个特殊值,令x=1;
则 (k*a+18)%65==0
由于抽屉原理可以知道, 上式最大65个(不同的数字)一循环,因为,a取不同的值,结果都不一样,所以可以 枚举 a 从1 到 65
代码
#include<stdio.h>
#include<string.h>
#include<math.h>
int main()
{
int k;
while(~scanf("%d",&k))
{
int i,j;
for(i=1;i<=66;i++) // 其实65 就可以
{
if((18+k*i)%65==0)
break;
}
if(i>66) printf("no\n");
else printf("%d\n",i);
}
return 0;
}