【LightOJ - 1370】 Bi-shoe and Phi-shoe 【欧拉值和素数的关系】

Bamboo Pole-vault is a massively popular sport in Xzhiland. And Master Phi-shoe is a very popular coach for his success. He needs some bamboos for his students, so he asked his assistant Bi-Shoe to go to the market and buy them. Plenty of Bamboos of all possible integer lengths (yes!) are available in the market. According to Xzhila tradition,

Score of a bamboo = Φ (bamboo’s length)

(Xzhilans are really fond of number theory). For your information, Φ (n) = numbers less than n which are relatively prime (having no common divisor other than 1) to n. So, score of a bamboo of length 9 is 6 as 1, 2, 4, 5, 7, 8 are relatively prime to 9.

The assistant Bi-shoe has to buy one bamboo for each student. As a twist, each pole-vault student of Phi-shoe has a lucky number. Bi-shoe wants to buy bamboos such that each of them gets a bamboo with a score greater than or equal to his/her lucky number. Bi-shoe wants to minimize the total amount of money spent for buying the bamboos. One unit of bamboo costs 1 Xukha. Help him.

Input
Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n ≤ 10000) denoting the number of students of Phi-shoe. The next line contains n space separated integers denoting the lucky numbers for the students. Each lucky number will lie in the range [1, 106].

Output
For each case, print the case number and the minimum possible money spent for buying the bamboos. See the samples for details.

Sample Input
3
5
1 2 3 4 5
6
10 11 12 13 14 15
2
1 1
Sample Output
Case 1: 22 Xukha
Case 2: 88 Xukha
Case 3: 4 Xukha
分析
1这里用欧拉函数,即:一个素数的比它小的互质数的个数为该数减一。
2 假如ψ(N)的欧拉函数值为p,则N的最小值为大于p的最小素数。

#include<bits/stdc++.h>
#define LL long long
using namespace std;
const int MAXN = 1e6+100;
const int MAXM = 1e5;
bool su[MAXN]={1,1,0};
void biao(){
    for(int i=2;i*i<=MAXN;i++){
        if(!su[i]) 
            for(int j=2*i;j<MAXN;j+=i)
                su[j]=1;
    }
}
int main(){
    biao();
    int t;cin>>t;int cas=1;
    while(t--){
        int n;
        scanf("%d",&n);
        LL ans=0;int arr;
        for(int i=1;i<=n;i++) {
            scanf("%d",&arr);
            for(int j=arr+1;j;j++)
                if(!su[j]) { ans+=j ; break;}
        }
        printf("Case %d: %lld Xukha\n",cas++,ans);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值