HDU 1266 Reverse Number 【坑较多】

题目传送门:点击打开链接

Reverse Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9922    Accepted Submission(s): 4406


Problem Description
Welcome to 2006'4 computer college programming contest!

Specially, I give my best regards to all freshmen! You are the future of HDU ACM! And now, I must tell you that ACM problems are always not so easy, but, except this one... Ha-Ha!

Give you an integer; your task is to output its reverse number. Here, reverse number is defined as follows:
1. The reverse number of a positive integer ending without 0 is general reverse, for example, reverse (12) = 21;
2. The reverse number of a negative integer is negative, for example, reverse (-12) = -21;
3. The reverse number of an integer ending with 0 is described as example, reverse (1200) = 2100.
 

Input
Input file contains multiple test cases. There is a positive integer n (n<100) in the first line, which means the number of test cases, and then n 32-bit integers follow.
 

Output
For each test case, you should output its reverse number, one case per line.
 

Sample Input
 
 
3 12 -12 1200
 

Sample Output
 
 
21 -21 2100
 

Author
lcy
 

Source
 

Recommend
lxj   |   We have carefully selected several similar problems for you:   1279  1256  1302  1276  1283


这题就是需要注意以下几种输入情况

输入
0
000
00021
-00021
12000
-12000
-000
输出
0
0
12
-12
21000
-21000
-000

其他就没啥了

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<stack>
using namespace std;
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        getchar();
        while(n--)
        {
            char num[1000];
            char num2[1000];
            scanf("%s",num);
            int len=strlen(num);

            int flag=0;

            for(int i=0; i<len; i++)
            {

                if(num[i]<='9'&&num[i]>'0')///先排除只含零的情况
                {
                    flag=1;
                    break;
                }
            }
            if(flag==0)
            {
                printf("%s\n",num);
                continue;
            }

            int ed=len-1;
            for(int i=len-1; i>=0; i--)
            {
                if(num[i]>'0'&&num[i]<='9')
                {
                    ed=i;
                    break;
                }
            }
            
            for(int i=0; i<len; i++)
            {
                if(num[i]=='-')
                {
                    printf("%c",num[i]);
                }
                else if(num[i]>'0'&&num[i]<='9')
                {
                    for(int j=ed;j>=i;j--)
                    {
                        printf("%c",num[j]);
                    }
                    printf("%s\n",num+ed+1);
                    break;
                }
            }

        }

    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值