HDU 1266 Reverse Number

156 篇文章 0 订阅
11 篇文章 0 订阅

/*
中文题目   相反的数字
中文翻译-大意   给你一个数,叫你求这个数的相反顺序的数,即21变成12,-12变成-21,1200变成2100
题目大意:求一个相反的数
解题思路:可以用字符串写,也可以直接写
难点详解:我一开始是直接写的,但要注意:定义输入的数字时,要定义成int的64位,不然就错,我到现在也不知道为啥
关键点:注意负号如何处理,还有就是数字后面的0如何处理
解题人:lingnichong
解题时间:2014-08-13 19:49:02
解题体会:用int型就是错,但用int64型的就过了。
*/


Reverse Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5100    Accepted Submission(s): 2376


Problem Description
Welcome to 2006'4 computer college programming contest!

Specially, I give my best regards to all freshmen! You are the future of HDU ACM! And now, I must tell you that ACM problems are always not so easy, but, except this one... Ha-Ha!

Give you an integer; your task is to output its reverse number. Here, reverse number is defined as follows:
1. The reverse number of a positive integer ending without 0 is general reverse, for example, reverse (12) = 21;
2. The reverse number of a negative integer is negative, for example, reverse (-12) = -21;
3. The reverse number of an integer ending with 0 is described as example, reverse (1200) = 2100.
 

Input
Input file contains multiple test cases. There is a positive integer n (n<100) in the first line, which means the number of test cases, and then n 32-bit integers follow.
 

Output
For each test case, you should output its reverse number, one case per line.
 

Sample Input
  
  
3 12 -12 1200
 

Sample Output
  
  
21 -21 2100
 

Author
lcy
 


#include<stdio.h>
int main()
{
	int t;
	int flag,temp;
	__int64 n,x;
	scanf("%d",&t);
	while(t--)
	{
		flag=x=temp=0;
		scanf("%I64d",&n);
		if(n<0)
		{
			n=-n;
			flag=1;
		}
		while(n)
		{
			x=x*10+n%10;
			n/=10;
			if(!x)
				temp++;
		}
	
		if(flag==1)
			printf("-%I64d",x);
		else
			printf("%I64d",x);
		while(temp--)
			printf("0");
		printf("\n");
	}
	
	return 0;
}


用字符串写的:


#include <stdio.h>
#include <string.h>
char s[10000000];
int main()
{  int t,i,j,k,m;
    scanf("%d",&t);
    while(t--){
      getchar(); 
      memset(s,'\0',sizeof(s));
      scanf("%s",s);
      m=strlen(s);
      for(i=m-1;i>0;i--)
        { if(s[i]!='0')
            break;}
      if(s[0]=='-') printf("%c",s[0]);
       for(j=i;j>0;j--)
          printf("%c",s[j]);
        if(s[0]!='-') printf("%c",s[0]);
       for(k=m-1;k>i;k--)
          printf("%c",'0');
         printf("\n"); i=j=k=0;     
    }
    return 0;
} 



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值