HDU 1024 Max Sum Plus Plus 【基础DP】【DP优化】【子段最大和】

Max Sum Plus Plus

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 34665    Accepted Submission(s): 12386


Problem Description
Now I think you have got an AC in Ignatius.L's "Max Sum" problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem.

Given a consecutive number sequence S 1, S 2, S 3, S 4 ... S x, ... S n (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ S x ≤ 32767). We define a function sum(i, j) = S i + ... + S j (1 ≤ i ≤ j ≤ n).

Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i 1, j 1) + sum(i 2, j 2) + sum(i 3, j 3) + ... + sum(i m, j m) maximal (i x ≤ i y ≤ j x or i x ≤ j y ≤ j x is not allowed).

But I`m lazy, I don't want to write a special-judge module, so you don't have to output m pairs of i and j, just output the maximal summation of sum(i x, j x)(1 ≤ x ≤ m) instead. ^_^
 

Input
Each test case will begin with two integers m and n, followed by n integers S 1, S 2, S 3 ... S n.
Process to the end of file.
 

Output
Output the maximal summation described above in one line.
 

Sample Input
 
 
1 3 1 2 32 6 -1 4 -2 3 -2 3
 
Sample Output
 
 
68
Hint
Huge input, scanf and dynamic programming is recommended.
 

Author
JGShining(极光炫影)
 

Recommend
We have carefully selected several similar problems for you:   1074  1025  1081  1080  1160 
 

求M子段最大和问题的转移方程为   (M个子段不一定是连续的,但一定不相交)

dp【i】【j】 = max(dp【i】【j-1】,dp【i-1】【K】) + num【j】

这里来解释一下转移方程

dp【i】【j】代表前j个数分成i份时的最大值

当选择dp【i】【j-1】时代表第j个数加入第i个子段 这时最大值为  dp【i】【j-1】 + num【j】,相当于前j-1个数分成i份,然后第j个数加入第i段

当选择dp【i-1】【K】时代表第j个数自己成为第i个子段。此处K的取值为0<k<j 代表前K个数分成i-1段,然后第j个数自己构成第i段。此处的dp【i-1】【k】需要取dp【i-1】【1】~dp【i-1】【j-1】这个范围中的最大值


优化

但问题是如果要这样求的话,时间复杂度过高。为n^3。我们需要降低复杂度。

降低复杂度的最直接的方法是删去最大值计算的过程,我们可以看到dp【i-1】【k】保存的是i的上个状态i-1的最大值。那我们每次求i状态时都保存此状态下的最大值,这样就可以把复杂度降为n^2


#include<bits/stdc++.h>
using namespace std;
#define LL long long
#define INF 0x7fffffff
#define M(a,b) memset(a,b,sizeof(a))
const int MAXN = 1e6+5;
LL dp [MAXN];
LL mx [MAXN];
LL num[MAXN];
int n,m;
LL  MAX;
int main()
{
    while(~scanf("%d %d",&m,&n))
    {
        for(int i=1; i<=n; i++)
        {
            scanf("%lld",&num[i]);
            mx[i]=0;
            dp[i]=0;
        }
        ///dp[t][j] = max(dp[t][j-1],dp[t-1][k]) + num[j];
        for(int i=1; i<=m; i++)
        {
            MAX = -INF;
            for(int j=i; j<=n; j++)///前j个数分为i份,则j一定大于等于i
            {
                dp[j] = max(dp[j-1],mx[j-1]) + num[j];
                mx[j-1] = MAX;
                MAX   = max(dp[j],MAX);///记录最大值
            }
        }
        printf("%lld\n",MAX);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值