HDU 1069 Monkey and Banana 【和最大子序列】【上升子序列】

Monkey and Banana

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 18611    Accepted Submission(s): 9904


Problem Description
A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height.

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked.

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.
 

Input
The input file will contain one or more test cases. The first line of each test case contains an integer n,
representing the number of different blocks in the following data set. The maximum value for n is 30.
Each of the next n lines contains three integers representing the values xi, yi and zi.
Input is terminated by a value of zero (0) for n.
 

Output
For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height".
 

Sample Input
 
     
1 10 20 30 2 6 8 10 5 5 5 7 1 1 1 2 2 2 3 3 3 4 4 4 5 5 5 6 6 6 7 7 7 5 31 41 59 26 53 58 97 93 23 84 62 64 33 83 27 0
 

Sample Output
 
     
Case 1: maximum height = 40 Case 2: maximum height = 21 Case 3: maximum height = 28 Case 4: maximum height = 342
 

Source
 

Recommend
JGShining
 

Statistic |  Submit |  Discuss | Note

题意:

一组研究人员正在设计一项实验,以测试猴子的智商。他们将挂香蕉在建筑物的屋顶,同时,提供一些砖块给这些猴子。如果猴子足够聪明,它应当能够通过合理的放置一些砖块建立一个塔,并爬上去吃他们最喜欢的香蕉。
研究人员有n种类型的砖块,每种类型的砖块都有无限个。第i块砖块的长宽高分别用xi,yi,zi来表示。 同时,由于砖块是可以旋转的,每个砖块的3条边可以组成6种不同的长宽高。
在构建塔时,当且仅当A砖块的长和宽都分别小于B砖块的长和宽时,A砖块才能放到B砖块的上面,因为必须留有一些空间让猴子来踩。
你的任务是编写一个程序,计算猴子们最高可以堆出的砖块们的高度。

思路:

            本题需要求一个最大和子序列,且子序列是上升的(长和宽)。并且某一块砖的个数是无限的。意思是你可以更改其摆放方式来得到不同的砖头。

            假设一个砖头的长宽高为x,y,z  入果x!=y!=z   那么通过不同的摆放方法,可以得出六种砖头:

                长 宽 高

        x y z
        x z y
        z x y
        z y x
        y z x
        y x z

                如果只有x=y   或者只有 x=z 或者只有 z= y 的话,摆放出来就只有三种情况。

                当X=Y=Z的时候,就只有一种情况。

                把所有的情况都加入到数组中,按照长宽排序后求和最大子序列即可。(只需将求最长上升子序列的做法稍作修改即可)


            

#include<cstdio>
#include<cmath>
#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
#define LL long long
#define M(a,b) memset(a,b,sizeof(a))
const int MAXN = 1e5+5;
struct Node
{
    int h,c,k;
    int dp;
} num[MAXN];
int dp[MAXN];
int x,y,z;
int n,len;
int Case = 1;
bool cmp(Node A,Node B)
{
    if(A.c==B.c)///按照长宽升序排序
    {
        return A.k<B.k;
    }
    else return A.c<B.c;
}

int main()
{
    while(~scanf("%d",&n)&&n)
    {
        M(num,0);
        M(dp,0);
        /*
        x y z
        x z y
        z x y
        z y x
        y z x
        y x z
        */
        len = 0;
        for(int i=0; i<n; i++)
        {
            scanf("%d %d %d",&x,&y,&z);
            if(x==y&&z==y&&x==z)///三者相等只有一种情况
            {
                num[len].h=x,num[len].c=y, num[len].k=z, num[len].dp = x;
                len++;
            }
            else if(x==y&&x!=z&&y!=z)///两者相等有三种情况
            {
                num[len].h=x, num[len].c=y, num[len].k=z,num[len].dp = x;
                len++;
                num[len].h=x, num[len].c=z, num[len].k=y,num[len].dp = x;
                len++;
                num[len].h=z, num[len].c=x, num[len].k=y,num[len].dp = z;
                len++;
            }
            else if(z==x&&z!=y&&x!=y)///两者相等有三种情况
            {
                num[len].h=x, num[len].c=y, num[len].k=z,num[len].dp = x;
                len++;
                num[len].h=y, num[len].c=z, num[len].k=x,num[len].dp = y;
                len++;
                num[len].h=z, num[len].c=x, num[len].k=y,num[len].dp = z;
                len++;
            }
            else if(z==y&&z!=x&&y!=x)///两者相等有三种情况
            {
                num[len].h=x, num[len].c=y, num[len].k=z,num[len].dp = x;
                len++;
                num[len].h=y, num[len].c=x, num[len].k=z,num[len].dp = y;
                len++;
                num[len].h=z, num[len].c=y, num[len].k=x,num[len].dp = z;
                len++;
            }
            else if(x!=y&&x!=z&&y!=z)///三者均不相等有六种情况
            {
                num[len].h=x, num[len].c=y, num[len].k=z,num[len].dp = x;
                len++;
                num[len].h=x, num[len].c=z, num[len].k=y,num[len].dp = x;
                len++;
                num[len].h=z, num[len].c=y, num[len].k=x,num[len].dp = z;
                len++;
                num[len].h=z, num[len].c=x, num[len].k=y,num[len].dp = z;
                len++;
                num[len].h=y, num[len].c=x, num[len].k=z,num[len].dp = y;
                len++;
                num[len].h=y, num[len].c=z, num[len].k=x,num[len].dp = y;
                len++;
            }
        }
        sort(num,num+len,cmp);
        int MAX = 0;
        for(int i=1; i<len; i++)
        {
            for(int j=0; j<i; j++)
            {
                if(num[i].k>num[j].k&&num[i].c>num[j].c)
                {
                    num[i].dp = max(num[j].dp+num[i].h,num[i].dp);///求高的和最大,不是求最长上升子序列

                }
            }
            MAX = max(MAX,num[i].dp);
        }
        printf("Case %d: maximum height = %d\n",Case++,MAX);
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值