大数的乘法

N!

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 83811    Accepted Submission(s): 24704


Problem Description
Given an integer N(0 ≤ N ≤ 10000), your task is to calculate N!
 

Input
One N in one line, process to the end of file.
 

Output
For each N, output N! in one line.
 

Sample Input
  
  
1 2 3
 

Sample Output
  
  
1 2 6

原题:http://acm.hdu.edu.cn/showproblem.php?pid=1042

#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<iostream>
using namespace std;
#define max 10000
#define base 100000//base取除10之外的值时要注意输出时除了第一个非0的数输出时不用注意格式
				//如果基数为10000,就要输出"%04d" ,因为会有前导0 ,基数越大计算次数越少 
int num[max];
int main()
{
	int aim,i,j;
	while(scanf("%d",&aim)!=EOF)
	{
		int carry=0;
		memset(num,0,sizeof(num));
		for(i=1,num[max-1]=1;i<=aim;i++)
		{
			for(j=max-1;j>=0;j--)
			{
				carry+=i*num[j];//不要忘了+  ,包含了上一位的进位 
				num[j]=carry%base;
				carry/=base;
			}
		}
		for(i=0;i<max && num[i]==0;i++); //找到第一个非0的数字,从此处开始输出 
			printf("%d",num[i++]);
		for(;i<max;i++)
			printf("%05d",num[i]);
		printf("\n");
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值