Have Fun With Numbers(大数模拟水题)

1023. Have Fun with Numbers (20)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!

Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

Input Specification:

Each input file contains one test case. Each case contains one positive integer with no more than 20 digits.

Output Specification:

For each test case, first print in a line "Yes" if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or "No" if not. Then in the next line, print the doubled number.

Sample Input:
1234567899
Sample Output:
Yes
2469135798

点击打开链接Pat甲 1023

题意就是看这个数字乘以二后,和原来数字的组成是不是相同,用两个数组标记下比一下就行了

坑点是如果组成不同。也需要打印数字的两倍。

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;
int num[30],res[30],count1[10],count2[10];
char str1[30];
int main()
{
	scanf("%s",&str1);
	int len=strlen(str1);
	int index=29;
	for(int i=len-1;i>=0;i--)
	{
		num[index--]=str1[i]-'0';
		count1[str1[i]-'0']++;
	}
	int carry=0;
	for(int i=29;i>=0;i--)
	{
		res[i]=(carry+num[i]*2)%10;
		carry=(carry+num[i]*2)/10;
	}
	index=0;
	while(res[index]==0)
		index++;
	for(int i=index;i<=29;i++)
		count2[res[i]]++;
	for(int i=0;i<=9;i++)
	{
		if(count1[i]!=count2[i])
		{
			printf("No\n");
			for(int k=index;k<=29;k++)
			{
				printf("%d",res[k]);
			}	
			printf("\n");
			return 0;
		}
	}
	printf("Yes\n");
	for(int i=index;i<=29;i++)
	{
		printf("%d",res[i]);
	}
	printf("\n");
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值