POJ 1383 Labyrinth(两次bfs求最长路径)

18 篇文章 0 订阅

The northern part of the Pyramid contains a very large and complicated labyrinth. The labyrinth is divided into square blocks, each of them either filled by rock, or free. There is also a little hook on the floor in the center of every free block. The ACM have found that two of the hooks must be connected by a rope that runs through the hooks in every block on the path between the connected ones. When the rope is fastened, a secret door opens. The problem is that we do not know which hooks to connect. That means also that the neccessary length of the rope is unknown. Your task is to determine the maximum length of the rope we could need for a given labyrinth.
Input
The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers C and R (3 <= C,R <= 1000) indicating the number of columns and rows. Then exactly R lines follow, each containing C characters. These characters specify the labyrinth. Each of them is either a hash mark (#) or a period (.). Hash marks represent rocks, periods are free blocks. It is possible to walk between neighbouring blocks only, where neighbouring blocks are blocks sharing a common side. We cannot walk diagonally and we cannot step out of the labyrinth. 
The labyrinth is designed in such a way that there is exactly one path between any two free blocks. Consequently, if we find the proper hooks to connect, it is easy to find the right path connecting them.
Output
Your program must print exactly one line of output for each test case. The line must contain the sentence "Maximum rope length is X." where Xis the length of the longest path between any two free blocks, measured in blocks.
Sample Input
2
3 3
###
#.#
###
7 6
#######
#.#.###
#.#.###
#.#.#.#
#.....#
#######
Sample Output
Maximum rope length is 0.
Maximum rope length is 8.
Hint
Huge input, scanf is recommended. 
If you use recursion, maybe stack overflow. and now C++/c 's stack size is larger than G++/gcc

题解:

题意:

给你一个图,点代表可以相连,问这个图中最长的线段

 思路:

先随意找一个点开始搜索它的最长路径的终点,然后从该终点出发再搜一次最长路径就是答案了

代码:

#include<algorithm>
#include<iostream>
#include<cstring>
#include<stdio.h>
#include<math.h>
#include<string>
#include<stdio.h>
#include<queue>
#include<stack>
#include<map>
#include<vector>
#include<deque>
using namespace std;
#define lson k*2
#define rson k*2+1
#define M (t[k].l+t[k].r)/2
#define INF 1008611111
int p[1005][1005],n,m;
char s[1005][1005];
int dirx[4]={0,0,-1,1};//方向数组
int diry[4]={-1,1,0,0};
int maxx,stx,sty;
struct node
{
    int x,y;
    int step;//为当前步数
};
void bfs(int x,int y)//从x,y开始的bfs求最长路径
{
    node now,next;
    queue<node>q;
    now.x=x,now.y=y,now.step=0;
    q.push(now);
    memset(p,0,sizeof(p));
    maxx=0;
    int i,j,xx,yy;
    p[x][y]=1;
    while(!q.empty())
    {
        now=q.front();
        q.pop();
        if(now.step>maxx)//保存最长路径的终点信息
        {
            maxx=now.step;
            stx=now.x;
            sty=now.y;
        }
        for(i=0;i<4;i++)
        {
            xx=now.x+dirx[i];
            yy=now.y+diry[i];
            if(xx>=0&&yy>=0&&xx<m&&yy<n&&!p[xx][yy]&&s[xx][yy]!='#')
            {
                p[xx][yy]=1;
                next.x=xx;
                next.y=yy;
                next.step=now.step+1;
                q.push(next);
            }
        }
    }
}
int main()
{
    int i,j,k,test;
    scanf("%d",&test);
    while(test--)
    {
         scanf("%d%d",&n,&m);
        for(i=0;i<m;i++)
        {
            scanf("%s",s[i]);
        }
        for(i=0;i<m;i++)
        {
            for(j=0;j<n;j++)
            {
                if(s[i][j]=='.')//随便找一个就好
                {
                    bfs(i,j);
                    goto loop;
                }
            }
        }
        loop:;
        bfs(stx,sty);//从找到的终点开始bfs
        printf("Maximum rope length is %d.\n",maxx);
    }
    return 0;
}




评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值