Godfather--找树的重心

Godfather
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 8614 Accepted: 3034

Description

Last years Chicago was full of gangster fights and strange murders. The chief of the police got really tired of all these crimes, and decided to arrest the mafia leaders.

Unfortunately, the structure of Chicago mafia is rather complicated. There are n persons known to be related to mafia. The police have traced their activity for some time, and know that some of them are communicating with each other. Based on the data collected, the chief of the police suggests that the mafia hierarchy can be represented as a tree. The head of the mafia, Godfather, is the root of the tree, and if some person is represented by a node in the tree, its direct subordinates are represented by the children of that node. For the purpose of conspiracy the gangsters only communicate with their direct subordinates and their direct master.

Unfortunately, though the police know gangsters’ communications, they do not know who is a master in any pair of communicating persons. Thus they only have an undirected tree of communications, and do not know who Godfather is.

Based on the idea that Godfather wants to have the most possible control over mafia, the chief of the police has made a suggestion that Godfather is such a person that after deleting it from the communications tree the size of the largest remaining connected component is as small as possible. Help the police to find all potential Godfathers and they will arrest them.

Input

The first line of the input file contains n — the number of persons suspected to belong to mafia (2 ≤ n ≤ 50 000). Let them be numbered from 1 to n.

The following n − 1 lines contain two integer numbers each. The pair aibi means that the gangster ai has communicated with the gangster bi. It is guaranteed that the gangsters’ communications form a tree.

Output

Print the numbers of all persons that are suspected to be Godfather. The numbers must be printed in the increasing order, separated by spaces.

Sample Input

6
1 2
2 3
2 5
3 4
3 6

Sample Output

2 3

随便找一个点为根节点,然后树形dp得到每个点的子节点的个数(包括自己)

对于每个点,去掉该点后的最大子树为它的子节点或者他的父节点所在联通的节点数

这道题用vector会超时,以后还是用数组模拟吧。。。

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<vector>
#include<algorithm>
#define inf 0x3f3f3f3f
#define maxn 50005
using namespace std;
int n;
int siz[maxn];
int maxson[maxn];
int ans;
struct node
{
    int u,v,next;
} edge[maxn*2];
int head[maxn];
void add(int u,int v,int &k)
{
    edge[k].u=u;
    edge[k].v=v;
    edge[k].next=head[u];
    head[u]=k++;
    swap(u,v);
    edge[k].u=u;
    edge[k].v=v;
    edge[k].next=head[u];
    head[u]=k++;
}
int dfs(int u,int fa)
{
    siz[u]=1;
    for(int k=head[u]; k!=-1; k=edge[k].next)
    {
        int v=edge[k].v;
        if(v==fa)
            continue;
        siz[u]=siz[u]+dfs(v,u);
    }
    maxson[u]=n-siz[u];
    for(int k=head[u]; k!=-1;k=edge[k].next)
    {
        int v=edge[k].v;
        if(v==fa)
            continue;
        maxson[u]=max(maxson[u],siz[v]);
    }
    ans=min(ans,maxson[u]);
    return siz[u];
}
int main()
{
    scanf("%d",&n);
    memset(head,-1,sizeof(head));
    memset(siz,0,sizeof(siz));
    int a,b;
    int num=0;
    for(int i=1; i<n; i++)
    {
        scanf("%d%d",&a,&b);
        add(a,b,num);
    }
    ans=inf;
    dfs(1,0);
    int arr[maxn];
    int cnt=0;
    bool flag=false;
    for(int i=1; i<=n; i++)
    {
        if(maxson[i]==ans)
        {
            if(!flag)
            {
                printf("%d",i);
                flag=true;
            }
            else
            {
                printf(" %d",i);
            }
        }
    }
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值