POJ-1002 487-3279

487-3279

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 331201 Accepted: 58635

Description

Businesses like to have memorable telephone numbers. One way to make a telephone number memorable is to have it spell a memorable word or phrase. For example, you can call the University of Waterloo by dialing the memorable TUT-GLOP. Sometimes only part of the number is used to spell a word. When you get back to your hotel tonight you can order a pizza from Gino’s by dialing 310-GINO. Another way to make a telephone number memorable is to group the digits in a memorable way. You could order your pizza from Pizza Hut by calling their ``three tens’’ number 3-10-10-10.
The standard form of a telephone number is seven decimal digits with a hyphen between the third and fourth digits (e.g. 888-1200). The keypad of a phone supplies the mapping of letters to numbers, as follows:
A, B, and C map to 2
D, E, and F map to 3
G, H, and I map to 4
J, K, and L map to 5
M, N, and O map to 6
P, R, and S map to 7
T, U, and V map to 8
W, X, and Y map to 9
There is no mapping for Q or Z. Hyphens are not dialed, and can be added and removed as necessary. The standard form of TUT-GLOP is 888-4567, the standard form of 310-GINO is 310-4466, and the standard form of 3-10-10-10 is 310-1010.
Two telephone numbers are equivalent if they have the same standard form. (They dial the same number.)
Your company is compiling a directory of telephone numbers from local businesses. As part of the quality control process you want to check that no two (or more) businesses in the directory have the same telephone number.

Input

The input will consist of one case. The first line of the input specifies the number of telephone numbers in the directory (up to 100,000) as a positive integer alone on the line. The remaining lines list the telephone numbers in the directory, with each number alone on a line. Each telephone number consists of a string composed of decimal digits, uppercase letters (excluding Q and Z) and hyphens. Exactly seven of the characters in the string will be digits or letters.

Output

Generate a line of output for each telephone number that appears more than once in any form. The line should give the telephone number in standard form, followed by a space, followed by the number of times the telephone number appears in the directory. Arrange the output lines by telephone number in ascending lexicographical order. If there are no duplicates in the input print the line:
No duplicates.

Sample Input

12
4873279
ITS-EASY
888-4567
3-10-10-10
888-GLOP
TUT-GLOP
967-11-11
310-GINO
F101010
888-1200
-4-8-7-3-2-7-9-
487-3279

Sample Output

310-1010 2
487-3279 4
888-4567 3

Source

http://poj.org/problem?id=1002

解释

本题是输入一堆的字符串,有如下映射规则:
A, B, and C map to 2
D, E, and F map to 3
G, H, and I map to 4
J, K, and L map to 5
M, N, and O map to 6
P, R, and S map to 7
T, U, and V map to 8
W, X, and Y map to 9
将其变成电话号码 电话号码的第四个字符为-
统计每个电话号码的出现个数,个数大于1输出电话号码和个数 按电话号码的字典序输出
如果没有重复的电话号码就打印
No duplicates.

定义一个mp来统计每个电话号码的个数,并记录
map<string,int>mp;
对于输入的每个字符串进行转换为电话号码tmp,然后加入mp[tmp]++;
然后最后再遍历对个数大于1进行输出即可

代码

#include<iostream>
#include<string>
#include<map>
int num[26]={2,2,2,3,3,3,4,4,4,5,5,5,6,6,6,7,7,7,7,8,8,8,9,9,9,9};
using namespace std;
int main()
{
	string a,tmp;
	map<string,int>mp;
	int n;
	cin>>n;
	while(n--)
	{
		cin>>a;
		for(int i=0;i<a.size();i++)
		{
			if(i==3)
			{
				tmp+='-';
			} 
			if(a[i]=='-')//对于-不进行处理 
				continue;
			if(a[i]>='A'&&a[i]<='Z')//字母的处理 
			{
				tmp+=(num[(a[i]-'A')]+'0');
			}
			else
			{
				tmp+=a[i];
			}
		}
		mp[tmp]++ ;// 加入map中 
		tmp="";
	}
	bool bRepeat=false;
	map<string,int>::const_iterator it;//遍历map 
	for (it= mp.begin();it != mp.end(); ++it )
    {
        if ( it->second > 1 )
        {
            cout << it->first << " " << it->second << endl;
            bRepeat = true;
        }
    }
    if(bRepeat==false)
    {
    	cout<<"No duplicates."<<endl;
	}
	return 0;
}

人一我百!人十我万!永不放弃~~~怀着自信的心,去追逐梦想。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

じ☆夏妮国婷☆じ

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值