Frequent values RMQ

Frequent values

You are given a sequence of n integers a1 , a2 , ... , an in non-decreasing order. In addition to that, you are given several queries consisting of indices i and j (1 ≤ i ≤ j ≤ n). For each query, determine the most frequent value among the integers ai , ... , aj.

Input

The input consists of several test cases. Each test case starts with a line containing two integers n and q (1 ≤ n, q ≤ 100000). The next line contains nintegers a1 , ... , an (-100000 ≤ ai ≤ 100000, for each i ∈ {1, ..., n}) separated by spaces. You can assume that for each i ∈ {1, ..., n-1}: ai ≤ ai+1. The following q lines contain one query each, consisting of two integers i and j (1 ≤ i ≤ j ≤ n), which indicate the boundary indices for the 
query.

The last test case is followed by a line containing a single 0.

Output

For each query, print one line with one integer: The number of occurrences of the most frequent value within the given range.

Sample Input
10 3
-1 -1 1 1 1 1 3 10 10 10
2 3
1 10
5 10
0
Sample Output
1
4
3


这题的意思是:给出n个数和Q个询问(l,r),对于每个询问求出(l,r)之间连续出现次数最多的次数。

将原序列转换一下,if(num[i]==num[i-1])   f[i]=f[i-1]+1;

                                else   f[i]++;

对于每个询问(l,r),分为两个部分,前半部分求与l之前相同的数的个数直到t,后半部分从t开始直接用RMQ求解最大值就行了。

最后结果为max(前半部分,后半部分)。


然后用RMQ

#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
#define MAXN 100000
#define INF 0x3f3f3f
using namespace std;
int dp[MAXN][50];
int n;
int a[MAXN],num[MAXN],rt[MAXN];
void rmqis()
{
    for(int j=1;(1<<j)<=n;j++)
    {
        for(int i=1;i+(1<<j)-1<=n;i++)
        {
            dp[i][j]=max(dp[i][j-1],dp[i+(1<<(j-1))][j-1]);
        }
    }
}
int rmq(int l,int r)
{
    if(l>r) return 0;
    int k=0;
    while((1<<(k+1))<=r-l+1) k++;
    return max(dp[l][k],dp[r-(1<<k)+1][k]);
}
int main()
{
    int q;
    while(scanf("%d",&n)&&n)
    {
        scanf("%d",&q);
        a[0]=INF;
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
            if(i==1)
                num[i]=1;
            else if(a[i]==a[i-1])
                num[i]=num[i-1]+1;
            else
                num[i]=1;
                dp[i][0]=num[i];
        }
        for(int i=n;i>=1;i--)
        {
            if(a[i]==a[i+1]) rt[i]=rt[i+1];
            else rt[i]=i;
        }
        rmqis();
        int l,r,t,ans,tm;
        while(q--)
        {
            scanf("%d%d",&l,&r);
            if(rt[l-1]==rt[l]) t=min(r,rt[l])+1;
            else t=l;
            tm=rmq(t,r);
            ans=max(tm,t-l);
            printf("%d\n",ans);
        }
    }
    return 0;
}

人一我百!人十我万!永不放弃~~~怀着自信的心,去追逐梦想。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

じ☆夏妮国婷☆じ

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值