Find them, Catch them 带权并查集

Find them, Catch them
Time Limit: 1000MS
Memory Limit: 10000K
Total Submissions: 46623
Accepted: 14352

Description

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.) 

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds: 

1. D [a] [b] 
where [a] and [b] are the numbers of two criminals, and they belong to different gangs. 

2. A [a] [b] 
where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang. 

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.

Output

For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."

Sample Input

1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4

Sample Output

Not sure yet.
In different gangs.
In the same gang.

Source



题意:
本题中只有两个集合,输入A i,j  让判断 i,j是否在一个集合,不确定就是Not sure yet.;D  i  j  是说i,j在不同集合;

par【i】表示是否出现过,r【i】表示在那个集合,分为0和1;



#include<iostream>
#include<algorithm>
#include<cstdio>
#include<string>
#include<string.h>
using namespace std;
const int N=10100000;
int par[N],r[N];


void init(int n)
{
for(int i=0;i<=n;i++)
{
par[i]=i;
r[i]=0;
}
}


int find(int x)
{
if(par[x]==x) return x;
int t=par[x];
par[x]=find(par[x]);
r[x]=(r[t]+r[x])%2;
return par[x];
}


void unite(int x,int y)
{
int ax=find(x);
int ay=find(y);
par[ax]=ay;;
r[ax]=(r[x]+1+r[y])%2;
}
bool same(int x,int y)
{
return find(x)==find(y);
}
int n,m;
int v,k;
string a="D",b;
bool visit[100010];


int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        init(n);
        while(m--)
        {
            cin>>b;
            scanf("%d%d",&v,&k);
            if(b==a)
            {
                if(!same(v,k))
                {
                    unite(v,k);
                }
            }
            else
            {
                if(find(v)!=find(k)) printf("Not sure yet.\n");
                else if(r[v]==r[k]) printf("In the same gang.\n");
                else printf("In different gangs.\n");
            }


        }
    }
    return 0;
}
人一我百!人十我万!永不放弃~~~怀着自信的心,去追逐梦想

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

じ☆夏妮国婷☆じ

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值