1051 Pop Sequence

1051 Pop Sequence (25 分)
Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, …, N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:
Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification:
For each pop sequence, print in one line “YES” if it is indeed a possible pop sequence of the stack, or “NO” if not.
Sample Input:
5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2
Sample Output:
YES
NO
NO
YES
NO
题目大意:
给定一个容量为m的栈,先分别把1,2,3…n依次入栈,并给出一系列出栈顺序,问这些出栈顺序是否可能。
解题思路:
将1~n依次入栈,在入栈的过程中如果入栈的元素恰好等于出栈序列当前等待出栈的元素,那么就让栈顶元素出栈,同时把出栈序列当前等待出栈的元素位置标记后移1位。只要栈顶元素仍然等于出栈序列当前等待出栈的元素,则持续出栈。

#include<cstdio>
#include<stack>
using namespace std;
const int maxn=1010;
int arr[maxn];//保存题目中给定的出栈顺序
stack<int> st;
int main()
{
	int m,n,T;
	scanf("%d%d%d",&m,&n,&T);
	while(T--)
	{
		while(!st.empty())//清空栈 
		{
			st.pop();
		}
		for(int i=1;i<=n;i++)
		{
			scanf("%d",&arr[i]);//读入数据 
		} 
		int current=1;//指向出栈序列中的待出栈元素
		bool flag=true;
		for(int i=1;i<=n;i++)
		{
			st.push(i);//把i压人栈
			if(st.size()>m) //如果此时栈中元素个数大于容量m,则序列非法 
			{
				flag=false;
				break;
			} 
			//栈顶元素与出栈序列当前位置的元素相同时
			while(!st.empty()&& st.top()==arr[current])
			{
				st.pop();//反复弹栈并令current++
				current++; 
			} 
		} 
		if(st.empty()==true && flag==true)
		{
			printf("YES\n");
		}
		else
		{
			printf("NO\n");
		}
	}
	return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值