1013 Battle Over Cities

1013 Battle Over Cities (25 分)
It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city
​1
​​ -city
​2
​​ and city
​1
​​ -city
​3
​​ . Then if city
​1
​​ is occupied by the enemy, we must have 1 highway repaired, that is the highway city
​2
​​ -city
​3
​​ .

Input Specification:
Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output Specification:
For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input:
3 2 3
1 2
1 3
1 2 3
Sample Output:
1
0
0
题意:
给定一个无向图并规定,当删除图中的某个顶点时,将会同时把与之连接的边一起删除,接下来给出k个查询,每个查询给出一个欲删除的顶点编号,求删除该顶点(和与其连接的边)后需要增加多少边,才能使图变为连通。
思考:
1.给定一个无向图,如何计算需要增加的边,使得整个图连通。
假设无向图G有n个连通块b1,b2,b3,…bn,在b1与b2之间加一条边,在b2与b3之间加一条边,…在bn-1与bn之间加一条边,可以使整个图G连通,且这种做法添加的边数一定是最少的。显然,需要添加的边数等于连通块个数减一。
2.该问题转化为求一个无向图G的连通块个数。
图的遍历:图的遍历过程中每次访问单个连通块,并将该连通块内的所有顶点都标记为已访问,然后访问下个连通块,因此可以在访问过程中计数遍历的连通块的个数。这样我们可以知道需要添加的边数。

#include<cstdio>
#include<cstring>
#include<vector>
using namespace std;
const int N=1111;
vector<int> G[N];//邻接表
bool vis[N];

int currentPoint;//当遍历到已删除顶点v时,返回
//dfs(v)遍历顶点v所在的连通块
void dfs(int v)
{
	if(v==currentPoint)
	return;//当遍历到已删除顶点v时,返回
	vis[v]=true;//标记顶点v已被访问
	for(int i=0;i<G[v].size();i++)
	{
		//遍历v的所有邻接点
		if(vis[G[v][i]]==false)
		{
			//如果顶点G[v][i]未被访问
			dfs(G[v][i]);//访问顶点G[v][i] 
		} 
	} 
} 
int n,m,k;
int main()
{
	scanf("%d%d%d",&n,&m,&k);//顶点数,边数,查询数 
	for(int i=0;i<m;i++)
	{
		int a,b;
		scanf("%d%d",&a,&b);//输入边的两个顶点
		G[a].push_back(b);//边a->b
		G[b].push_back(a);//边b->a 
	}
	for(int query=0;query<k;query++)
	{
		//k次查询
		scanf("%d",&currentPoint);//被删除的顶点编号
		memset(vis,false,sizeof(vis));//初始化vis数组为false
		int block=0;//连通块个数,初值为0
		for(int i=1;i<=n;i++)
		{
			//枚举每个顶点 
			if(i!=currentPoint && vis[i]==false)
			{
			    //如果未被删除且未被访问
				dfs(i);//遍历顶点i所在的连通块
				block++;	
			}
		} 
		printf("%d\n",block-1);//输出连通块个数减1,表示需要增加的边 
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值