Battle Over Cities(做题思路总结)

Battle Over Cities

题目

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city​1 -city​2​​ and city​1​​ -city​3​​ . Then if city​1​​ is occupied by the enemy, we must have 1 highway repaired, that is the highway city​2​​ -city​3​​ .

Input Specification:
Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output Specification:
For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input:

3 2 3
1 2
1 3
1 2 3

Sample Output:

1
0
0

答案

#include<iostream>
#include<vector>
#include<cstring>
using namespace std;
int n,m,k,vis[1005];
int map[1005][1005];

void dfs(int root)
{
	vis[root]=1;
	for(int i=1;i<=n;i++)
	{
		if(vis[i]==0&&map[root][i]==1)
		dfs(i);
	}
}

int main()
{
	cin>>n>>m>>k;
	while(m--)
	{
		int x,y;
		cin>>x>>y;
		map[x][y]=map[y][x]=1;
	}
	while(k--)
	{
		int tmp,count=0;
		cin>>tmp;
		memset(vis,0,sizeof(vis));
		vis[tmp]=1;
		for(int i=1;i<=n;i++)
		{
			if(vis[i]==0) 
			{
				dfs(i);
				count++;
			}
		}
		cout<<count-1<<endl;
	}
}

做题思路总结

首先我想到了并查集,但在实际编程中发现,并查集在涉及删除(忽视)某些节点时并不好用

接下来我想到了用vector,但在dfs的过程中不是很方便,至少不如最后的二维数组方便

最后我借鉴了这篇文章的代码——Battle Over Cities (25)

这道题的本质就是计算连通分支的个数,每一个dfs结束后都代表一个联通分支出现,又因为有vis的存在,能够避免重复。

  • 2
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 2
    评论
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值