1018 Public Bike Management

1018 Public Bike Management (30 分)
There is a public bike service in Hangzhou City which provides great convenience to the tourists from all over the world. One may rent a bike at any station and return it to any other stations in the city.

The Public Bike Management Center (PBMC) keeps monitoring the real-time capacity of all the stations. A station is said to be in perfect condition if it is exactly half-full. If a station is full or empty, PBMC will collect or send bikes to adjust the condition of that station to perfect. And more, all the stations on the way will be adjusted as well.

When a problem station is reported, PBMC will always choose the shortest path to reach that station. If there are more than one shortest path, the one that requires the least number of bikes sent from PBMC will be chosen.

The above figure illustrates an example. The stations are represented by vertices and the roads correspond to the edges. The number on an edge is the time taken to reach one end station from another. The number written inside a vertex S is the current number of bikes stored at S. Given that the maximum capacity of each station is 10. To solve the problem at S
​3
​​ , we have 2 different shortest paths:

PBMC -> S
​1
​​ -> S
​3
​​ . In this case, 4 bikes must be sent from PBMC, because we can collect 1 bike from S
​1
​​ and then take 5 bikes to S
​3
​​ , so that both stations will be in perfect conditions.

PBMC -> S
​2
​​ -> S
​3
​​ . This path requires the same time as path 1, but only 3 bikes sent from PBMC and hence is the one that will be chosen.

Input Specification:
Each input file contains one test case. For each case, the first line contains 4 numbers: C
​max
​​ (≤100), always an even number, is the maximum capacity of each station; N (≤500), the total number of stations; S
​p
​​ , the index of the problem station (the stations are numbered from 1 to N, and PBMC is represented by the vertex 0); and M, the number of roads. The second line contains N non-negative numbers C
​i
​​ (i=1,⋯,N) where each C
​i
​​ is the current number of bikes at S
​i
​​ respectively. Then M lines follow, each contains 3 numbers: S
​i
​​ , S
​j
​​ , and T
​ij
​​ which describe the time T
​ij
​​ taken to move betwen stations S
​i
​​ and S
​j
​​ . All the numbers in a line are separated by a space.

Output Specification:
For each test case, print your results in one line. First output the number of bikes that PBMC must send. Then after one space, output the path in the format: 0−>S
​1
​​ −>⋯−>S
​p
​​ . Finally after another space, output the number of bikes that we must take back to PBMC after the condition of S
​p
​​ is adjusted to perfect.

Note that if such a path is not unique, output the one that requires minimum number of bikes that we must take back to PBMC. The judge’s data guarantee that such a path is unique.

Sample Input:
10 3 3 5
6 7 0
0 1 1
0 2 1
0 3 3
1 3 1
2 3 1
Sample Output:
3 0->2->3 0
这道题好难!!!!理解题目意思都花了好久
题意:
城市里的一些公共自行车站,每个车站的自行车最大容量为一个偶数Cmax,且如果一个车站中自行车的数量恰好为Cmax/2,则这个车站处于“完美状态”。而如果一个车站容量是满的或是空的。则会从控制中心(PBMC)携带或从路上收集一定数量的自行车前往该车站。使每个问题车站及沿途所有车站都达到“完美状态”。现在给出Cmax,车站数目N(不含控制中心PBNC),问题车站编号Sp,无向边数M及边权,求一条从PBMC(记为0号)到达问题车站Sp的最短路径,输出需要从PBMC携带的自行车数目,最短路径,到达问题车站后需要带回的自行车数目。如果最短路径有多条,那么选择从PBMC携带的自行车数目最少的;如果仍然有多条,那么选择最后从问题车站带回的自行车数目最少的。
!!!沿途所有车站的调整过程必须在前往问题车站的过程中调整完毕。

#include<cstdio>
#include<cstring>
#include<vector>
#include<algorithm>
using namespace std;
const int MAXV=510;//最大顶点数
const int INF=1000000;//无穷大

//n为顶点数,m为边数,Cmax为最大容量,Sp为问题站点
//G为邻接矩阵,weight为点权,d[]记录最短距离
//minNeed记录最少携带的数目,minRemain记录最少带回的数目
int n,m,Cmax,Sp,numPath=0,G[MAXV][MAXV],weight[MAXV];
int d[MAXV],minNeed=INF,minRemain=INF;
bool vis[MAXV]={false};
vector<int> pre[MAXV];//前驱
vector<int> tempPath,path;//临时路径及最优路径
void Dijkstra(int s)
{
	fill(d,d+MAXV,INF);
	d[s]=0;
	for(int i=0;i<=n;i++)
	{
		//循环n+1次
		int u=-1,MIN=INF;//u使d[u]最小,MIN存放该最小的d[u]
		for(int j=0;j<=n;j++)
		{
			//找到未访问的顶点中d[]最小的
			if(vis[j]==false && d[j]<MIN)
			{
				u=j;
				MIN=d[j];
			} 
		} 
		//找不到小于INF的d[u],说明剩下的顶点和起点s不连通
	  if(u==-1)return;
	  vis[u]=true;//标记u为已访问
	  for(int v=0;v<=n;v++)
	  {
  		//如果v未访问&& u能到达v
		  if(vis[v]==false && G[u][v]!=INF)
		  {
  			if(d[u]+G[u][v]<d[v])
  			{
			  	d[v]=d[u]+G[u][v];//优化d[v]
				pre[v].clear();
				pre[v].push_back(u); 
		    }else if(d[u]+G[u][v]==d[v])
		    {
    			pre[v].push_back(u);
    		}
    	} 
  	  } 
	} 
} 
void DFS(int v)
{
	if(v==0)
	{
		//递归边界,叶子结点
		tempPath.push_back(v);
		//路径tempPath上需要携带的数目,需要带回的数目
		int need=0,remain=0;
		for(int i=tempPath.size()-1;i>=0;i--)
		{
			int id=tempPath[i];//当前结点编号为id
			if(weight[id]>0)
			{
				//点权大于0,说明需要带走一部分自行车
				remain+=weight[id];//当前自行车持有量增加weight[id] 
			}else{
				if(remain>abs(weight[id]))
				{
					//当前持有量足够补给
					remain-=abs(weight[id]);//当前持有量减少补给的量
						 
				}else{
					need+=abs(weight[id])-remain;//不够的部分从PBMC携带
					remain=0;//当前持有的自行车全部用来补给 
				} 
			}
		} 
		if(need<minNeed)
		{
			//需要从PBMC携带的自行车数目更少
			minNeed=need;//优化minNeed
			minRemain=remain;//覆盖minRemain
			path=tempPath;//覆盖最优路径 
		}else if(need==minNeed && remain<minRemain)
		{
			//携带数目相同,带回数目变少
			minRemain=remain;//优化minRemain
			path=tempPath;//覆盖最优路径 
		} 
		tempPath.pop_back();
	    return;
	
	}
	tempPath.push_back(v);
	for(int i=0;i<pre[v].size();i++)
	{
		DFS(pre[v][i]);
	}
	tempPath.pop_back();
}
int main()
{
	scanf("%d%d%d%d",&Cmax,&n,&Sp,&m);
	int u,v;
	fill(G[0],G[0]+MAXV*MAXV,INF);
	for(int i=1;i<=n;i++)
	{
		scanf("%d",&weight[i]);
		weight[i]-=Cmax/2;//点权减去容量的一半 
	}
	for(int i=0;i<m;i++)
	{
		scanf("%d%d",&u,&v);
		scanf("%d",&G[u][v]);
		G[v][u]=G[u][v];
	} 
	Dijkstra(0);
	DFS(Sp);
	printf("%d ",minNeed);
	for(int i=path.size()-1;i>=0;i--)
	{
		printf("%d",path[i]);
		if(i>0)printf("->");
	}
	printf(" %d",minRemain);
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 3
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 3
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值