D

Description

The SUM problem can be formulated as follows: given four lists A, B, C, D of integer values, compute how many quadruplet (a, b, c, d ) ∈ A x B x C x D are such that a + b + c + d = 0 . In the following, we assume that all lists have the same size n .

Input

The first line of the input file contains the size of the lists n (this value can be as large as 4000). We then have n lines containing four integer values (with absolute value as large as 2  28 ) that belong respectively to A, B, C and D .

Output

For each input file, your program has to write the number quadruplets whose sum is zero.

Sample Input

6
-45 22 42 -16
-41 -27 56 30
-36 53 -37 77
-36 30 -75 -46
26 -38 -10 62
-32 -54 -6 45

Sample Output

5

Hint

Sample Explanation: Indeed, the sum of the five following quadruplets is zero: (-45, -27, 42, 30), (26, 30, -10, -46), (-32, 22, 56, -46),(-32, 30, -75, 77), (-32, -54, 56, 30).


题目分析

有abcd四个数组,各抽取一个数使得四个数之和为0,问共有多少种取法能达到目的

解题思路

从这四个数列中选择的话总有n的4次方中情况,所以全部判断一遍不可行。不过将他们对半分成AB和CD再考虑的话就可以解决了。从两个数列中选择的话只有n的2次方中组合。所以可以枚举。从A,B中取出a,b后,为了使总和为0则需要从C,D中取出a+b=-(c+d);先将a和b数组的和存在一个数组ab里面,再将c和d相加的相反数-(c+d)在ab数组里面查找,二分查找可以做。

源代码

#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
using namespace std;
int n;
int a[4001],b[4001],c[4001],d[4001];
int cd[4001*4001];
void solve()
{
    for(int i=0; i<n; ++i)
        for(int j=0; j<n; ++j)
            cd[i*n+j]=c[i]+d[j];
    sort(cd,cd+n*n);
    long long res=0;
    for(int i=0; i<n; ++i)
        for(int j=0; j<n; ++j)
        {
            int addcd=-(a[i]+b[j]);
            res+=upper_bound(cd,cd+n*n,addcd)-lower_bound(cd,cd+n*n,addcd);
        }
    cout<<res<<endl;
}
int main()
{
    cin>>n;
    for(int i=0; i<n;i++)
        cin>>a[i]>>b[i]>>c[i]>>d[i];
    solve();
    return 0;
}

注意

upper_bound返回第一个出现的位置  
lower_bound返回最后一个的后面一个出现的位置  
都没有就返回应该出现的位置使得sort依然有序

又get到了一些东西


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值