B骑士旅行

Description

Background
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey 
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans? 

Problem
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.

Input

The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number. 
If no such path exist, you should output impossible on a single line.

Sample Input

3
1 1
2 3
4 3

Sample Output

Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4
 
     
 
     
题目分析
给出一个p行q列的国际棋盘,马可以从任意一个格子开始走,问马能否不重复的走完所有的棋盘。如果可以,输出按字典序排列最小的路径。
解题思路
如果马可以不重复的走完所有的棋盘,那么它一定可以走到A1这个格子。所以我们只需从A1这个格子开始搜索,就能保证字典序是小的;除了这个条件,我们还要控制好马每次移动的方向,控制方向时保证字典序最小。控制好这两个条件,直接从A1开始深搜就行了。
源代码
#include<cstdio>  
#include<cstring>  
#include<algorithm>  
using namespace std;  
int path[88][88], vis[88][88], p, q, cnt;  
bool flag;   
int dx[8] = {-1, 1, -2, 2, -2, 2, -1, 1};  
int dy[8] = {-2, -2, -1, -1, 1, 1, 2, 2};  
bool judge(int x, int y)  
{  
    if(x >= 1 && x <= p && y >= 1 && y <= q && !vis[x][y] && !flag)  
        return true;  
    return false;  
}  
  
void DFS(int r, int c, int step)  
{  
    path[step][0] = r;  
    path[step][1] = c;  
    if(step == p * q)  
    {  
        flag = true;  
        return ;  
    }  
    for(int i = 0; i < 8; i++)  
    {  
        int nx = r + dx[i];  
        int ny = c + dy[i];  
        if(judge(nx,ny))  
        {  
  
            vis[nx][ny] = 1;  
            DFS(nx,ny,step+1);  
            vis[nx][ny] = 0;  
        }  
    }  
}  
  
int main()  
{  
    int i, j, n, cas = 0;  
    scanf("%d",&n);  
    while(n--)  
    {  
        flag = 0;  
        scanf("%d%d",&p,&q);  
        memset(vis,0,sizeof(vis));  
        vis[1][1] = 1;  
        DFS(1,1,1);  
        printf("Scenario #%d:\n",++cas);  
        if(flag)  
        {  
            for(i = 1; i <= p * q; i++)  
                printf("%c%d",path[i][1] - 1 + 'A',path[i][0]);  
        }  
        else  
            printf("impossible");  
        printf("\n");  
        if(n != 0)  
            printf("\n");  
    }  
    return 0;  
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值