RXD and math (hdu 6063) 2017多校第三场

RXD and math
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 524288/524288 K (Java/Others)
Total Submission(s): 310    Accepted Submission(s): 160


Problem Description
RXD is a good mathematician.
One day he wants to calculate:

output the answer module .


 are different prime numbers
 

Input
There are several test cases, please keep reading until EOF.
There are exact 10000 cases.
For each test case, there are 2 numbers .
 

Output
For each test case, output "Case #x: y", which means the test case number and the answer.
 

Sample Input
10 10
 

Sample Output
Case #1: 999999937
 

Source
2017 Multi-University Training Contest - Team 3

首先看出来u()函数是莫比乌斯函数

然后手动打表找出来的规律,发现结果为n的k次方

利用快速幂直接求就可以了

#include<cstdio>
#include<iostream>
using namespace std;
const long long int mod=1e9+7;
long long int fast_pow_mod(long long int a,long long int b)
{
  long long int res=1;
  while(b)
  {
    if(b&1) res=res*a%mod;
    a=((a%mod)*(a%mod))%mod;
    b>>=1;
  }
  return res;
}
int main()
{
  long long int n,k;
  long long int cas=1;
  while(scanf("%lld%lld",&n,&k)!=EOF)
  {
  long long int w;
  w=fast_pow_mod(n,k);
  printf("Case #%lld: %lld\n",cas++,w%mod);
  }
  return 0;
}

不是数学方面的,直接从网上捞了个快速幂模板发现wa了一次,后来自己写了一遍,发现是爆long long 了,过程中也要mod

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值