【LightOJ 】- 1410 思维 算出两点间距离+去重

题目描述了平面上N个人开枪的情况,每个人的位置用坐标表示,且每个人听力范围相同。求所有可能的、一致的听枪声次数报告的总数。一致的报告意味着每个人的报告基于他们听到的枪声数是合理的。解决方案是计算所有两点间的距离并去重,统计不同的距离数量,包括距离为0的情况。
摘要由CSDN通过智能技术生成

In a 2D plane N persons are standing and each of them has a gun in his hand. The plane is so big that the persons can be considered as points and their locations are given as Cartesian coordinates. Each of the N persons fire the gun in his hand exactly once and no two of them fire at the same or similar time (the sound of two gun shots are never heard at the same time by anyone so no sound is missed due to concurrency). The hearing ability of all these persons is exactly same. That means if one person can hear a sound at distance R1, so can every other person and if one person cannot hear a sound at distance R2 the other N-1 persons cannot hear a sound at distance R2 as well.

The N persons are numbered from 1 to N. After all the guns are fired, all of them are asked how many gun shots they have heard (not including their own shot) and they give their verdict. It is not possible for you to determine whether their verdicts are true but it is possible for you to judge if their verdicts are consistent. For example, look at the figure above. There are five persons and their coordinates are (1, 2), (3, 1), (5, 1), (6, 3) and (1, 5) and they are numbered as 1, 2, 3, 4 and 5 respectively. After all five of them have shot their guns, you ask them how many shots each of them have heard. Now if there response is 1, 1, 1, 2 and 1 respectively then you can represent it as (1, 1, 1, 2, 1). But this is an inconsistent verdict because if person 4 hears 2 shots then he must have heard the shot fired by person 2, then obviously person 2 must have heard the shot fired by person 1, 3 and 4 (person 1 and 3 are nearer to person 2 than person 4). But their opinions show that Person 2 says that he has heard only 1 shot. On the other hand (1, 2, 2, 1, 0) is a consistent verdict for this scenario so is (2, 2, 2, 1, 1). In this scenario (5, 5, 5, 4, 4) is not a consistent verdict because a person can hear at most 4 shots.

Given the locations of N persons, your job is to find the total number of different consistent verdicts for that scenario. Two verdicts are different if opinion of at least one person is different.

Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case starts with a line containing a positive integer N (1 ≤ N ≤ 700). Each of the next N lines contains two integers xi yi (0 ≤ xi, yi ≤ 30000) denoting a co-ordinate of a person. Assume that all the co-ordinates are distinct.

Output

For each case, print the case number and the total number of different consistent verdicts for the given scenario.

Sample Input

2

3

1 1

2 2

4 4

2

1 1

5 5

Sample Output

Case 1: 4

Case 2: 2

 

题意:平面上给出 n 个人的坐标,任意两个人均不可能在同一个时刻开枪,但是由于人能听见声音的距离是有限的,由于每个人位置的不同,所以每个人听到的枪声次数不同,问能给出每个人能听到枪声次数合理的方案有几种。

思路:可以观察到,每一个不同的方案就是每两点的距离,统计有几个不同距离就行了。计算出每两点之间的距离,去重后看有多少个就行了。记得加上距离为 0 的情况。

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<string>
#include<cstring>
#include<cmath>
#include<ctime>
#include<algorithm>
#include<utility>
#include<stack>
#include<queue>
#include<vector>
#include<set>
#include<map>
#define PI acos(-1.0)
#define E 1e-6
#define MOD 1000000007
#define INF 0x3f3f3f3f
#define maxn 3e5+10
using namespace std;
#define ll long long int
using namespace std;
int x[705],y[705],vis[705*705];
int main()
{
    int t,N,num=1;
    scanf("%d",&t);
    while(t--)
    {
        int n=0;
        int ans=1;
        scanf("%d",&N);
        for(int i=1;i<=N;i++)
            scanf("%d %d",&x[i],&y[i]);
        for(int i=1;i<=N;i++)
            for(int j=i+1;j<=N;j++)
                vis[++n]=(x[i]-x[j])*(x[i]-x[j])+(y[i]-y[j])*(y[i]-y[j]);
        sort(vis+1,vis+1+n);
        for(int i=2;i<=n;i++)
          if(vis[i]!=vis[i-1])
            ans++;
        printf("Case %d: %d\n",num++,++ans);
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值