202:Repeating Decimals

45 篇文章 0 订阅
2 篇文章 0 订阅

The decimal expansion of the fraction 1/33 is 0.03, where the 03 is used to indicate that the cycle 03repeats indefinitely with no intervening digits. In fact, the decimal expansion of every rational number(fraction) has a repeating cycle as opposed to decimal expansions of irrational numbers, which have nosuch repeating cycles.

  Examples of decimal expansions of rational numbers and their repeating cycles are shown below. Here, we use parentheses to enclose the repeating cycle rather than place a bar over the cycle.


  Write a program that reads numerators and denominators of fractions and determines their repeatingcycles.

  For the purposes of this problem, define a repeating cycle of a fraction to be the first minimal lengthstring of digits to the right of the decimal that repeats indefinitely with no intervening digits. Thusfor example, the repeating cycle of the fraction 1/250 is 0, which begins at position 4 (as opposed to 0which begins at positions 1 or 2 and as opposed to 00 which begins at positions 1 or 4).

Input

Each line of the input file consists of an integer numerator, which is nonnegative, followed by an integerdenominator, which is positive. None of the input integers exceeds 3000. End-of-file indicates the endof input.

Output

For each line of input, print the fraction, its decimal expansion through the first occurrence of the cycleto the right of the decimal or 50 decimal places (whichever comes first), and the length of the entirerepeating cycle.

  In writing the decimal expansion, enclose the repeating cycle in parentheses when possible. If theentire repeating cycle does not occur within the first 50 places, place a left parenthesis where the cyclebegins — it will begin within the first 50 places — and place ‘...)’ after the 50th digit.

Sample Input

76 25

5 43

1 397

Sample Output

76/25 = 3.04(0)

    1 = number of digits in repeating cycle

5/43 = 0.(116279069767441860465)

    21 = number of digits in repeating cycle

1/397 = 0.(00251889168765743073047858942065491183879093198992...)

    99 = number of digits in repeating cycle


World Finals >> 1990 - Washington

这道题思路很清晰,记录每次相除后的余数,如果余数之前出现过就说明循环出现,1且循环一定出现在前(除数)次相除之内,因为余数只能是0 ——除数 -1。刚开始写的代码如下:

#include<cstdio>
#include<cstring>
using namespace std;
const int maxn = 100000 + 5;
int main(){
    int a,b;
    while(scanf("%d%d",&a,&b) != EOF){
        int i = 0,Int = 0,a1 = a;
        int nu[b] = {0},id[b] = {0},de[maxn] = {0};
        if(a > b){
            Int = a / b;
            a %= b;
        }
        while(a){
            a *= 10;
            while(a && a < b){
                a *= 10;
                i++;
            }
            de[i] = a / b;
            a %= b;
            if(nu[a]) break;
            nu[a] = 1;
            id[a] = ++i;
        }
        i++;
        int circle = i - id[a];
        while(de[i-1] == de[i - 1 - circle] && i - 1 - circle >= 0) i--;
        int start = i - circle;
        printf("%d/%d = %d.",a1,b,Int);
        for(int i = 0;i < start;i++) printf("%d",de[i]);
        putchar('(');
        int j;
        for(j = start;j < i && j < start + 50;j++){
            printf("%d",de[j]);
        }
        if(j == start + 50) printf("...");
        printf(")\n   %d = number of digits in repeating cycle\n\n",circle);
        //for(int j =0;j < i;j++) printf("%d ",de[j]);
    }

    return 0;
}
太丑了,而且还是WA,于是就边找bug边修改,最后发现 a = b 的情况出问题了,最后AC的代码如下:

#include<cstdio>
using namespace std;
const int maxn = 3000 + 5;
int main(){
    int a,b;
    while(scanf("%d%d",&a,&b) != EOF){
        int i = 0,a1 = a;
        int nu[b] = {0},id[b] = {0},de[maxn] = {0};
        if(a >= b) a %= b;//一定要是 a >= b,不然a = b时就不对了
        while(!nu[a]){
            nu[a] = 1;
            id[a] = i;
            a *= 10;
            de[i++] = a / b;
            a %= b;
        }
        int start = id[a],cycle = i - id[a];
        printf("%d/%d = %d.",a1,b,a1/b);
        for(int i = 0;i < start;i++) printf("%d",de[i]);
        putchar('(');
        for(int j = start;j < i && j < 50;j++){
            printf("%d",de[j]);
        }
        if(i > 50) printf("...");
        printf(")\n   %d = number of digits in repeating cycle\n\n",cycle);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值