POJ-1947-Rebuilding Roads

Rebuilding Roads
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 12302 Accepted: 5702

Description

The cows have reconstructed Farmer John's farm, with its N barns (1 <= N <= 150, number 1..N) after the terrible earthquake last May. The cows didn't have time to rebuild any extra roads, so now there is exactly one way to get from any given barn to any other barn. Thus, the farm transportation system can be represented as a tree.

Farmer John wants to know how much damage another earthquake could do. He wants to know the minimum number of roads whose destruction would isolate a subtree of exactly P (1 <= P <= N) barns from the rest of the barns.

Input

* Line 1: Two integers, N and P

* Lines 2..N: N-1 lines, each with two integers I and J. Node I is node J's parent in the tree of roads.

Output

A single line containing the integer that is the minimum number of roads that need to be destroyed for a subtree of P nodes to be isolated.

Sample Input

11 6
1 2
1 3
1 4
1 5
2 6
2 7
2 8
4 9
4 10
4 11

Sample Output

2

Hint

[A subtree with nodes (1, 2, 3, 6, 7, 8) will become isolated if roads 1-4 and 1-5 are destroyed.]

Source

题意:删除几条边能够得到想要的拥有m个节点的子树。

这题就不用解释了,直接dp求想要i个节点的子树需要删除多少个边,层层递推就行了。

代码:

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<vector>
#include<math.h>
using namespace std;
int n,p;
int bj[155],dp[155][155];
int tree[155],nnext[155];
void csh()
{
memset(bj,0,sizeof(bj));
memset(tree,0,sizeof(tree));
memset(nnext,0,sizeof(nnext));
memset(dp,0,sizeof(dp));
}
void dfs(int now)
{
for(int i=0;i<=p;i++)
    dp[now][i]=999999999;
dp[now][1]=0;
for(int i=nnext[now];i!=0;i=tree[i])
    {
    dfs(i);
    for(int j=p;j>=1;j--)
        {
        int s=dp[now][j]+1;
        for(int k=1;k<j;k++)
            s=min(s,dp[i][j-k]+dp[now][k]);
        dp[now][j]=s;
        }
    }
}
int main()
{
int fa,son,root,s;
while(cin>>n>>p)
    {
    csh();
    for(int i=0;i<n-1;i++)
        {
        scanf("%d%d",&fa,&son);
        bj[son]=1;
        tree[son]=nnext[fa];
        nnext[fa]=son;
        }
    for(int i=1;i<=n;i++)
        if(!bj[i])
            {
            root=i;
            break;
            }
    dfs(root);
    s=dp[root][p];
    for(int i=1;i<=n;i++)
        s=min(s,dp[i][p]+1);
    cout<<s<<endl;
    }
return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值