openjudge-2456——Aggressive cows(二分法)

2456:Aggressive cows

总时间限制:

1000ms

内存限制:

65536kB

描述

Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,...,xN (0 <= xi <= 1,000,000,000).

His C (2 <= C <= N) cows don't like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?

输入

* Line 1: Two space-separated integers: N and C

* Lines 2..N+1: Line i+1 contains an integer stall location, xi

输出

* Line 1: One integer: the largest minimum distance

样例输入

5 3
1
2
8
4
9

样例输出

3

提示

OUTPUT DETAILS:

FJ can put his 3 cows in the stalls at positions 1, 4 and 8, resulting in a minimum distance of 3.

Huge input data,scanf is recommended.

#include<bits/stdc++.h>
using namespace std;
const int N=100050;
int dst[N];
int n,c;
int main(){
	scanf("%d%d",&n,&c);
	for(int i=1;i<=n;i++){
		scanf("%d",&dst[i]);
	}
	sort(dst+1,dst+n+1);
	int max_x=dst[n]-dst[1];
	int min_x=0;
	while(min_x<max_x){
		int mid=(max_x+min_x+1)/2;
		//每次第一个位置都需要放才能保证最大距离的最小值
		int pre=1,cnt=c-1; 
		for(int i=2;i<=n;i++){
			if(dst[i]-dst[pre]>=mid){
				cnt--;
				pre=i;
				
			}
			if(cnt==0) break;	
		}
		if(cnt==0){
			min_x=mid;
		}else{
			max_x=mid-1;
		}
	}
	cout<<max_x<<endl;
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值