4-adjacent

Problem Statement
We have a sequence of length N, a=(a1,a2,…,aN). Each ai is a positive integer.

Snuke's objective is to permute the element in a so that the following condition is satisfied:

For each 1≤i≤N−1, the product of ai and ai+1 is a multiple of 4.
Determine whether Snuke can achieve his objective.

Constraints
2≤N≤105
ai is an integer.
1≤ai≤109
Input
Input is given from Standard Input in the following format:

N
a1 a2 … aN
Output
If Snuke can achieve his objective, print Yes; otherwise, print No.

Sample Input 1
3
1 10 100
Sample Output 1
Yes
One solution is (1,100,10).

Sample Input 2
4
1 2 3 4
Sample Output 2
No
It is impossible to permute a so that the condition is satisfied.

Sample Input 3
3
1 4 1
Sample Output 3
Yes
The condition is already satisfied initially.

Sample Input 4
2
1 1
Sample Output 4
No
Sample Input 5
6
2 7 1 8 2 8
Sample Output 5

Yes

#include<stdio.h>
int main ()
{
	int i,n;
	while(scanf("%d",&n)!=EOF)
	{
		int a=0,b=0,t;
		for(i=0;i<n;i++)
		{
			scanf("%d",&t);
			if(t%2==0)
				a++;
			if(t%4==0)
				b++;
		//	printf("%d %d %d\n",a,b,n);
		}
		a=a-b;
		if((n-a)<=2*b&&a!=0)
			printf("Yes\n");
		else if((n-a-1)<=2*b&&a==0)
			printf("Yes\n");
		else
			printf("No\n");
	}
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值