POJ1276----Cash Machine 多重背包

http://poj.org/problem?id=1276

Description
A Bank plans to install a machine for cash withdrawal. The machine is able to deliver appropriate @ bills for a requested cash amount. The machine uses exactly N distinct bill denominations, say Dk, k=1,N, and for each denomination
 Dk the machine has a supply of nk bills. For example, 
N=3, n1=10, D1=100, n2=4, D2=50, n3=5, D3=10 
means the machine has a supply of 10 bills of @100 each, 4 bills of @50 each, and 5 bills of @10 each.

Call cash the requested amount of cash the machine should deliver and write a program that computes the maximum amount of cash less than or equal to cash that can be effectively delivered according to the available bill supply of the machine.

Notes: 
@ is the symbol of the currency delivered by the machine. For instance, @ may stand for dollar, euro, pound etc.

Input
The program input is from standard input. Each data set in the input stands for a particular transaction and has the format:

cash N n1 D1 n2 D2 ... nN DN 
where 0 <= cash <= 100000 is the amount of cash requested, 0 <=N <= 10 is the number of bill denominations and 0 <= nk <= 1000 is the number of available bills for the Dk denomination, 1 <= Dk <= 1000, k=1,N. White spaces can occur freely between the numbers
 in the input. The input data are correct. 
Output
For each set of data the program prints the result to the standard output on a separate line as shown in the examples below.

Sample Input
735 3  4 125  6 5  3 350
633 4  500 30  6 100  1 5  0 1
735 0
0 3  10 100  10 50  10 10
Sample Output
735
630
0
0
Hint
The first data set designates a transaction where the amount of cash requested is @735. The machine contains 3 bill denominations: 4 bills of @125, 6 bills of @5, and 3 bills of @350. The machine can deliver the exact amount of
 requested cash. 
In the second case the bill supply of the machine does not fit the exact amount of cash requested. The maximum cash that can be delivered is @630. Notice that there can be several possibilities to combine the bills in the machine for matching the delivered
 cash. 
In the third case the machine is empty and no cash is delivered. In the fourth case the amount of cash requested is @0 and, therefore, the machine delivers no cash.
--------------------- 
作者:键盘上的舞者 
来源:CSDN 
原文:https://blog.csdn.net/libin56842/article/details/9473019 
版权声明:本文为博主原创文章,转载请附上博文链接!

题意:给出一个价值cash(金额,相当于背包容量),然后给出n,代表n种钞票(相当于n个物品),接着n对代表个数与面值(相当于物品i的个数与体积),要求最接近cash,但不超过cash的价值(尽量将背包装满,但不能超过背包容量)

思路:这题一看就知道是多重背包,直接挨个考虑不太行,得加点剪枝思维,倒是不难理解,

代码:

解法1:这个解法比较有趣,利用了二进制,可以构成任意数的特点,。

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int dp[100005], V;
void Alone(int use)
{
	int v;
	for(v=V;v>=use;v--)
		dp[v] = max(dp[v], dp[v-use]+use);
}
void Every(int use)
{
	int v;
	for(v=use;v<=V;v++)
		dp[v] = max(dp[v], dp[v-use]+use);
}
void Mulitp(int n, int use)
{
	int k;
	if(use>V)
		return;
	if(use*n>=V)
		Every(use);///当前物品最大体积总体积超过背包,背包容量为优先限制条件。相当于可以往背包内放任意多个的做法;
	else
	{
		k = 1;
		while(k<n)///依次往背包内放1,2,4,8。。。个物品,跟据2进制特点,可以组合成任意值,并且个数永远不会超过物品的最大数量。所以可以依次选择放进背包。
		{
			Alone(k*use);
			n -= k; 
			k *= 2;
		}
		Alone(n*use);
	}
}
int main(void)
{
	int i, n, s[15], val[15];
	while(scanf("%d", &V)!=EOF)
	{
		memset(dp, 0, sizeof(dp));
		scanf("%d", &n);
		for(i=1;i<=n;i++)
			scanf("%d%d", &s[i], &val[i]);
		for(i=1;i<=n;i++)
			Mulitp(s[i], val[i]);
		printf("%d\n", dp[V]);
	}
}

解法2:
比较常规,也是不错的解法

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
 
struct node
{
    int n,v;
} a[20];

int dp[100010];

int main()
{
    int sum,n,i,j,k;
    while(~scanf("%d%d",&sum,&n))
    {
        for(i = 1; i<=n; i++)
            scanf("%d%d",&a[i].n,&a[i].v);
        if(!sum)
        {
            printf("0\n");
            continue;
        }
        if(!n)
        {
            printf("0\n");
            continue;
        }
        memset(dp,0,sizeof(dp));
        dp[0] = 1;
        int MAX = 0,tem;
        for(i = 1; i<=n; i++)
        {
            for(j = MAX;j>=0;j--)///已放入的背包的最大容量,包含所有dp值为1的最小区间
            {
                if(dp[j])///可以往背包内放物品
                {
                    for(k = 1;k<=a[i].n;k++)///zaij的基础上,按个数考虑往背包内放。。
                    {
                        tem = j+k*a[i].v;
                        if(tem>sum)
                        break;
                        dp[tem] = 1;
                        if(tem>MAX)
                        MAX = tem;
                    }
                }
            }
        }
        printf("%d\n",MAX);
    }
    return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值