POJ 2631 Roads in the North (树的直径裸题)

Description 
Building and maintaining roads among communities in the far North is an expensive business. With this in mind, the roads are build such that there is only one route from a village to a village that does not pass through some other village twice. 
Given is an area in the far North comprising a number of villages and roads among them such that any village can be reached by road from any other village. Your job is to find the road distance between the two most remote villages in the area. 
The area has up to 10,000 villages connected by road segments. The villages are numbered from 1.

Input 
Input to the problem is a sequence of lines, each containing three positive integers: the number of a village, the number of a different village, and the length of the road segment connecting the villages in kilometers. All road segments are two-way.

Output 
You are to output a single integer: the road distance between the two most remote villages in the area.

Sample Input 
5 1 6 
1 4 5 
6 3 9 
2 6 8 
6 1 7

Sample Output 
22 
题意:求树上最长的两个点之间的距离 

求树上最长的两个点之间的距离。这里有一个结论,在图中,要找到距离最远的两点,先随便从一个点入手bfs,找到距离这个点最远的点,在从这个点bfs找到距离这点最远的点,这两点之间的距离就是这颗树的直径。即首先从树上任意一个点a出发, (BFS)找出到这个点距离最远的点b. 然后在从b点出发(BFS)找到距离b点最远的点c. 那么bc间的距离就是树的直径.所以直接进行bfs搜索就行了

 

#include <iostream>
#include <cstring>
#include <queue>
#include <vector>

const int maxn =100020;

using namespace std;

int dis[maxn],ans;
bool vis[maxn];
vector<pair<int,int> >V[maxn];

int bfs(int x){
    memset (dis ,0 ,sizeof(dis) );
    memset (vis ,0 ,sizeof(vis) );
    queue <int >Q;
    Q.push(x); vis[x]=1;
    int point =0;
    while (!Q.empty()){
        int F = Q.front();
        Q.pop();
        if(dis[F]>ans){
            ans = dis[F];
            point = F;
        }
        pair <int,int>t;
        for (int i=0;i<V[F].size();i ++){
            t=V[F][i];
            if(vis [t.first]==0){
            vis [t.first]=1;
            dis [t.first]= dis[F]+t.second ;
            Q.push(t.first );
            }
        }
    }
    return point;
}

int main (){
    int x,y,z;
    while (cin>>x>>y>>z){
        V[x].push_back( make_pair(y,z));
        V[y].push_back( make_pair(x,z));
    }
    ans =0;
    int point =bfs(1);
    ans =0;
    bfs(point);
    cout <<ans<<endl ;
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值