POJ 2631 Roads in the North(村庄最大距离,树的直径,经典题目)

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 2554 Accepted: 1257

Description

Building and maintaining roads among communities in the far North is an expensive business. With this in mind, the roads are build such that there is only one route from a village to a village that does not pass through some other village twice. 
Given is an area in the far North comprising a number of villages and roads among them such that any village can be reached by road from any other village. Your job is to find the road distance between the two most remote villages in the area. 

The area has up to 10,000 villages connected by road segments. The villages are numbered from 1. 

Input

Input to the problem is a sequence of lines, each containing three positive integers: the number of a village, the number of a different village, and the length of the road segment connecting the villages in kilometers. All road segments are two-way.

Output

You are to output a single integer: the road distance between the two most remote villages in the area.

Sample Input

5 1 6
1 4 5
6 3 9
2 6 8
6 1 7

Sample Output

22

Source



题意:

给定一些村庄的距离,问哪两个最远。


键入数据:

村庄编号 村庄编号 距离

村庄编号  村庄编号 距离

村庄编号  村庄编号 距离

终止条件!=EOF


思路:

就是简单的树的直径,愣是对着宇神的代码,打了一个小时哭


代码:1736K 32MS

#include<stdio.h>
#include<string.h>
#include<queue>
using namespace std;
const int MYDD=110300;

int edgenum;//边的数目
int head[MYDD];//节点头指针
void init_edge() {
	edgenum=0;
	memset(head,-1,sizeof(head));
}

struct EDGE { //边的信息
	int u,v,w,next;
} edge[MYDD*2];
void addedge(int u,int v,int w) {//增加边信息
	EDGE Edge= {u,v,w,head[u]};//可以学习这种方法赋值
	edge[edgenum]=Edge;
	head[u]=edgenum++;
}

bool vis[MYDD];//记录节点的访问状态
int dis[MYDD];//记录节点所在直径的最大值
int Tnode,ans;
void BFS(int sx) {
	queue<int> Q;
	memset(vis,false,sizeof(vis));
	memset(dis,0,sizeof(dis));
	vis[sx]=true;
	Q.push(sx);
	Tnode=sx;
	ans=0;
	while(!Q.empty()) {
		int first=Q.front();//队列头元素 
		Q.pop();
		for(int j=head[first]; j!=-1; j=edge[j].next) {
			int v=edge[j].v;//当前边的终结点 
			if(!vis[v]) {
				if(dis[v]<edge[j].w+dis[first]) {
					dis[v]=edge[j].w+dis[first];
				}
				vis[v]=true;
				Q.push(v);
				if(ans<dis[v]) {//找到最大直径 
					ans=dis[v];
					Tnode=v;
				}
			}
		}
	}
}

int main() {
	int u,v,w;
	init_edge(); //漏掉后超时 
	while(scanf("%d%d%d",&u,&v,&w)!=EOF) {
		addedge(u,v,w);//坑人的结束方式 
		addedge(v,u,w);
	}
	BFS(1);
	BFS(Tnode);
	printf("%d\n",ans);
}



后:

继续敲

***************************


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值