ZOJ 2724 Windows Message Queue

Windows Message Queue

Time Limit: 2 Seconds      Memory Limit: 65536 KB

Message queue is the basic fundamental of windows system. For each process, the system maintains a message queue. If something happens to this process, such as mouse click, text change, the system will add a message to the queue. Meanwhile, the process will do a loop for getting message from the queue according to the priority value if it is not empty. Note that the less priority value means the higher priority. In this problem, you are asked to simulate the message queue for putting messages to and getting message from the message queue.

Input

There's only one test case in the input. Each line is a command, "GET" or "PUT", which means getting message or putting message. If the command is "PUT", there're one string means the message name and two integer means the parameter and priority followed by. There will be at most 60000 command. Note that one message can appear twice or more and if two messages have the same priority, the one comes first will be processed first.(i.e., FIFO for the same priority.) Process to the end-of-file.

Output

For each "GET" command, output the command getting from the message queue with the name and parameter in one line. If there's no message in the queue, output "EMPTY QUEUE!". There's no output for "PUT" command.

Sample Input

GET
PUT msg1 10 5
PUT msg2 10 4
GET
GET
GET

Sample Output

EMPTY QUEUE!
msg2 10
msg1 10
EMPTY QUEUE!

题目大意是说windows的消息队列的实现方式(好像是,其实我连题目意思都没怎么看,拿着样例输入输出就大概知道要怎么写了)

这道题要用到优先队列,而且需要自己设置优先级,定义一个结构体即可,最后面那个数字小的优先级高。

struct Node{
  int x,y;
  string s;
  bool operator < (const Node &a)const{
    return y>a.y;
  }
}a[60010];

用一个结构体数组储存输入的信息,每次有‘GET'时都要判断队列是否为空,有输出的时候记得要将队首弹出

#include<iostream>
#include<string>
#include<cstdio>
#include<queue>
using namespace std;
struct Node{
  int x,y;
  string s;
  bool operator < (const Node &a)const{
    return y>a.y;
  }
}a[60010];
int main(){
  string str;
  priority_queue<Node> que;
  int kount=0;
  while(cin>>str){
    if(str[0]=='G'){
      if(que.empty()){
        printf("EMPTY QUEUE!\n");
      }
      else{
        cout<<que.top().s<<" "<<que.top().x<<endl;
        que.pop();
      }
    }
    else{
      cin>>a[kount].s>>a[kount].x>>a[kount].y;
      que.push(a[kount++]);
    }
  }
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值