UVa 12096 stl之stack

Background from Wikipedia: “Set theory is a
branch of mathematics created principally by the
German mathematician Georg Cantor at the end of
the 19th century. Initially controversial, set theory
has come to play the role of a foundational theory
in modern mathematics, in the sense of a theory
invoked to justify assumptions made in mathematics
concerning the existence of mathematical objects
(such as numbers or functions) and their properties.
Formal versions of set theory also have a foundational
role to play as specifying a theoretical ideal
of mathematical rigor in proofs.”
Given this importance of sets, being the basis of mathematics, a set of eccentric theorist set off to
construct a supercomputer operating on sets instead of numbers. The initial SetStack Alpha is under
construction, and they need you to simulate it in order to verify the operation of the prototype.
The computer operates on a single stack of sets, which is initially empty. After each operation, the
cardinality of the topmost set on the stack is output. The cardinality of a set S is denoted |S| and is the
number of elements in S. The instruction set of the SetStack Alpha is PUSH, DUP, UNION, INTERSECT,
and ADD.
• PUSH will push the empty set {} on the stack.
• DUP will duplicate the topmost set (pop the stack, and then push that set on the stack twice).
• UNION will pop the stack twice and then push the union of the two sets on the stack.
• INTERSECT will pop the stack twice and then push the intersection of the two sets on the stack.
• ADD will pop the stack twice, add the first set to the second one, and then push the resulting set
on the stack.
For illustration purposes, assume that the topmost element of the stack is
A = {{}, {{}}}
and that the next one is
B = {{}, {{{}}}}
For these sets, we have |A| = 2 and |B| = 2. Then:
• UNION would result in the set {{}, {{}}, {{{}}}}. The output is 3.
• INTERSECT would result in the set {{}}. The output is 1.
• ADD would result in the set {{}, {{{}}}, {{},{{}}}}. The output is 3.

Input

An integer 0 ≤ T ≤ 5 on the first line gives the cardinality of the set of test cases. The first line of each
test case contains the number of operations 0 ≤ N ≤ 2000. Then follow N lines each containing one of
the five commands. It is guaranteed that the SetStack computer can execute all the commands in the
sequence without ever popping an empty stack.

Output

For each operation specified in the input, there will be one line of output consisting of a single integer.
This integer is the cardinality of the topmost element of the stack after the corresponding command
has executed. After each test case there will be a line with ‘***’ (three asterisks).

Sample Input

2
9
PUSH
DUP
ADD
PUSH
ADD
DUP
ADD
DUP
UNION
5
PUSH
PUSH
ADD
PUSH
INTERSECT

Sample Output

0
0
1
0
1
1
2
2
2
***
0
0
1
0
0

***


题目大意:

对一个存放集合的栈有五种操作;

  • PUSH:向栈中放一个空集合。
  • DUP:复制栈顶集合。
  • UNION:取栈顶的两个集合,取并集后放回。
  • INTERSECT:取栈顶的两个集合,取交集后放回。
  • ADD:取栈顶两个集合,将第一个集合作为元素放到第二个集合中,并将第二个集合放回栈。

每次操作后输出栈顶集合中元素的个数。


解题思路:

集合的表示形式是set,因为set的特性是每种元素只有一个不会出现重复的情况,符合集合的定义。相同的集合我们使用map为集合标记上唯一的映射ID。使用vector保存出现过的所有集合。stack中储存的是集合对应的ID值。对集合操作的时候是直接对set的集合运算。

#include <iostream>
#include <cstdio>
#include <map>
#include <set>
#include <stack>
#include <vector>
#include <string>
using namespace std;
typedef set<int > Set;
map< set<int> ,int > ma;
vector< set<int> > ve;

int ID(set<int> se)
{
    if(ma.count(se))
        return ma[se];
    else
    {
        ve.push_back(se);
        return ma[se] = ve.size() - 1;
    }
}
int main()
{
    //freopen("in.txt","r",stdin);
    int T,n;
    cin>>T;
    stack<int> st;
    while(T--)
    {
        string s;
        scanf("%d",&n);
        for(int f=0;f<n;f++)
        {
            cin>>s;
            if(s[0]=='P')
            {
                st.push(ID(*(new Set())));
            }
            else if(s[0]=='D')
            {
                st.push(st.top());
            }
            else
            {
                Set se1=ve[st.top()];
                st.pop();
                Set se2=ve[st.top()];
                st.pop();
                Set se;
                if(s[0]=='U')
                {
                    for(Set::iterator i = se1.begin(); i!=se1.end();i++)
                    {
                        se2.insert(*i);
                    }
                    se=se2;
                }else if(s[0]=='I')
                {
                 for(Set::iterator i = se1.begin(); i!=se1.end();i++)
                    for(Set::iterator j = se2.begin(); j!=se2.end();j++)
                    {
                        if(*i==*j)
                        {
                            se.insert(*i);
                            break;
                        }
                    }
                }else
                {
                    se2.insert(ID(se1));
                    se=se2;
                }
                st.push(ID(se));
            }
            cout<<ve[st.top()].size()<<endl;
        }
        cout<<"***"<<endl;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值