3752走迷宫(bfs)

题目描述
一个迷宫由R行C列格子组成,有的格子里有障碍物,不能走;有的格子是空地,可以走。
给定一个迷宫,求从左上角走到右下角最少需要走多少步(数据保证一定能走到)。只能在水平方向或垂直方向走,不能斜着走。

Input
第一行是两个整数,R和C,代表迷宫的长和宽。( 1<= R,C <= 40)
接下来是R行,每行C个字符,代表整个迷宫。
空地格子用’.’表示,有障碍物的格子用’#’表示。
迷宫左上角和右下角都是’.’。
Output
输出从左上角走到右下角至少要经过多少步(即至少要经过多少个空地格子)。计算步数要包括起点和终点。
Sample Input

5 5
…###
#…
#.#.#
#.#.#
#.#…

Sample Output
9

#include<iostream>
#include<queue>
using namespace std;
char aa[100][100];
int dir[4][2]={-1,0,1,0,0,-1,0,1};
int vis[100][100]={0};
int m,n;

typedef struct NODE{
	int x;
	int y;
	int step;
}node;

int bfs(int a,int b){
	node temp,next;
	temp.x=a;
	temp.y=b;
	temp.step=1;
	vis[temp.x][temp.y]=1;
	queue<node> q;
	q.push(temp);
	while(!q.empty()){	
		temp=q.front();
		q.pop();
		for(int i=0;i<4;i++){
			next.x=temp.x+dir[i][0];
			next.y=temp.y+dir[i][1];
			next.step=temp.step+1;
			if(next.x<0 || next.y<0 ||next.x>m || next.y>n ||vis[next.x][next.y]==1 ||aa[next.x][next.y]=='#'){
				continue;
			}
			if(next.x==m-1 &&next.y==n-1){
				return next.step;
			}
			vis[next.x][next.y]=1;
			q.push(next);
		}
		
	}
}



int main(){

	cin>>m>>n;
	
	for(int i=0;i<m;i++){
		for(int j=0;j<n;j++){
			cin>>aa[i][j];
		}
	}	
	int ans=bfs(0,0);
	cout<<ans;
	
	
	return 0;
}

ask
?能否用 dsf解决?

以下是Java中使用BFS算法解决走迷宫问题的示例代码: ```java import java.util.*; public class MazeBFS { static int[][] maze = {{0, 0, 0, 0, 0, 0, 0, 0}, {0, 1, 0, 1, 1, 1, 0, 0}, {0, 1, 0, 0, 0, 0, 0, 0}, {0, 1, 1, 1, 0, 1, 1, 0}, {0, 1, 0, 0, 0, 0, 1, 0}, {0, 1, 1, 1, 1, 1, 1, 0}, {0, 0, 0, 0, 0, 0, 0, 0}}; static int[][] direction = {{1, 0}, {-1, 0}, {0, 1}, {0, -1}}; public static void main(String[] args) { int startX = 1; int startY = 1; int endX = 5; int endY = 6; Queue<Node> queue = new LinkedList<>(); boolean[][] visited = new boolean[maze.length][maze[0].length]; Node startNode = new Node(startX, startY, 0); queue.offer(startNode); visited[startX][startY] = true; while (!queue.isEmpty()) { Node node = queue.poll(); int x = node.x; int y = node.y; int step = node.step; if (x == endX && y == endY) { System.out.println(step); break; } for (int i = 0; i < 4; i++) { int nextX = x + direction[i][0]; int nextY = y + direction[i][1]; if (nextX >= 0 && nextX < maze.length && nextY >= 0 && nextY < maze[0].length && maze[nextX][nextY] == 0 && !visited[nextX][nextY]) { queue.offer(new Node(nextX, nextY, step + 1)); visited[nextX][nextY] = true; } } } } static class Node { int x; int y; int step; public Node(int x, int y, int step) { this.x = x; this.y = y; this.step = step; } } } ``` 在上述代码中,我们使用了一个Node类来表示迷宫中的每个节点,其中包含了x和y坐标以及当前步数step。我们使用一个来进BFS搜索,并且使用一个二维布尔数组visited来记录每个节点是否已经被访问过。 我们从起点开始,将其加入队中,并将其visited值设为true。然后不断从队中取出节点进搜索,直到队为空或者找到终点为止。对于每个节点,我们尝试向四个方向扩展,如果扩展出来的节点在迷宫范围内、不是墙、没有被访问过,就将其加入队中,并将visited值设为true。 最终,如果搜索到了终点,就输出步数并停止搜索。如果队为空仍然没有找到终点,说明终点不可达。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值