PAT-A 1029 Median (25 point(s))

1029 Median (25 point(s))

Given an increasing sequence S of N integers, the median is the number at the middle position. For example, the median of S1 = { 11, 12, 13, 14 } is 12, and the median of S2 = { 9, 10, 15, 16, 17 } is 15. The median of two sequences is defined to be the median of the nondecreasing sequence which contains all the elements of both sequences. For example, the median of S1 and S2 is 13.

Given two increasing sequences of integers, you are asked to find their median.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, each gives the information of a sequence. For each sequence, the first positive integer N (≤2×10​5​​) is the size of that sequence. Then N integers follow, separated by a space. It is guaranteed that all the integers are in the range of long int.

Output Specification:

For each test case you should output the median of the two given sequences in a line.

Sample Input:

4 11 12 13 14
5 9 10 15 16 17

Sample Output:

13

思路:内存限制1.5M,如果两个数组的长度都是2×10​^5,那么刚好会超出1.5M,导致卡一个点,因此第二个数组不能一次性输入后再进行计算。每输入第二个数组中的一个数字,进行判断。如果第二个数组中的数字完全输入后还是没有正确答案,那么中位数就在第一个数组中。

#include <cstdio>

int main()
{
    int m;//第一个数组的长度
    scanf("%d", &m);
    int a[m + 1];
    for(int i = 0; i < m; i++)
        scanf("%d", a + i);
    a[m] = (1 << 31) - 1;//在第一个数字最后追加INT_MAX,当作哨兵,减少特判
    
    int n;//第二个数组的长度
    scanf("%d", &n);

    int pos = (m + n - 1) / 2;//合并后的数组的中位数的下标
    int temp;//临时保存第二个数组中的一个数字
    int count = -1;//当前数字在合并后的数组中的下标
    int j = 0;//指向第一个数组中待比较的数字
    for(int i = 0; i < n; i++)
    {
        scanf("%d", &temp);//输入一个第二个数组中的数
        while(j <= m && a[j] < temp)
        {
            count++;//更新数字放入合并后的数组中时的下标
            if(count == pos)//当前数字是中位数
            {
                printf("%d", a[j]);
                return 0;
            }
            j++;
        }
        //执行到这里,a[j] >= temp,将temp"放入"新数组
        count++;
        if(count == pos)
        {
            printf("%d", temp);
            return 0;
        }
    }

    //中位数在第一个串中
    while(j < m)
    {
        count++;
        if(count == pos)
        {
            printf("%d", a[j]);
            return 0;
        }
        j++;
    }
    printf("\n");//防止出现没有答案的情况,实际上本题没有这种情况
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值