PAT-A 1023 Have Fun with Numbers (20 point(s))

1023 Have Fun with Numbers (20 point(s))

Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!

Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

Input Specification:

Each input contains one test case. Each case contains one positive integer with no more than 20 digits.

Output Specification:

For each test case, first print in a line "Yes" if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or "No" if not. Then in the next line, print the doubled number.

Sample Input:

1234567899

Sample Output:

Yes
2469135798

思路:20位的整数乘以2,最大是21位,long long大致范围为9*10^18,因此只能自己写大整数乘法运算,这里采用算法笔记上的大整数思路.

#include <cstdio>
#include <cstring>

struct bign
{
    int d[25]; //最多20位, 乘2后最多21位
    int len;
    bign()
    {
        memset(d, 0, sizeof(d));
        len = 0;
    }
};
// 将字符串转换成bign
bign toBign(char str[])
{
    bign a;
    a.len = strlen(str);
    for(int i = 0; i < a.len; i++)
        a.d[a.len - 1 - i] = str[i] - '0';
    while(a.len > 1 && a.d[a.len - 1] == 0) // 防止输入000的情况
        a.len--;
    return a;
}
// bign和int的乘法
bign multi(bign a, int b)
{
    bign c;
    int carry = 0;
    int temp;
    for(int i = 0; i < a.len; i++)
    {
        temp = a.d[i] * b + carry;
        c.d[c.len++] = temp % 10;
        carry = temp / 10;
    }
    if(carry != 0)
    {
        c.d[c.len++] = carry % 10;
        carry /= 10;
    }
    return c;
}
int main()
{
    char in[30];
    scanf("%s", in);

    bign origin = toBign(in);
    bign doubled = multi(origin, 2);

    int count1[10] = {0}; //输入数字中每个个位数的出现次数
    int count2[10] = {0};

    for(int i = 0; i < origin.len; i++)
        count1[origin.d[i]]++;
    for(int i = 0; i < doubled.len; i++)
        count2[doubled.d[i]]++;

    bool flag = true;
    for(int i = 0; i < 10; i++)
        if(count1[i] != count2[i])
            flag = false;

    if(flag)
        printf("Yes\n");
    else
        printf("No\n");
    for(int i = 0; i < doubled.len; i++)
        printf("%d", doubled.d[doubled.len - 1 - i]);
    return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值