hdoj 1570 A C

A C(链接)

Problem Description
Are you excited when you see the title "AC" ? If the answer is YES , AC it ;

You must learn these two combination formulas in the school . If you have forgotten it , see the picture.




Now I will give you n and m , and your task is to calculate the answer .
 

Input
In the first line , there is a integer T indicates the number of test cases.
Then T cases follows in the T lines.
Each case contains a character 'A' or 'C', two integers represent n and m. (1<=n,m<=10)
 

Output
For each case , if the character is 'A' , calculate A(m,n),and if the character is 'C' , calculate C(m,n).
And print the answer in a single line.
 

Sample Input
   
   
2 A 10 10 C 4 2
 

Sample Output
   
   
3628800 6

因为n,m的范围比较小,直接求出 1 - 10 的阶乘就好了 

#include<cstdio>
#include<algorithm>
using namespace std;

int T,n,m,a[20];
char c;

//计算阶乘  注意 0
void init()
{
    int ans=1;
    a[0]=1;
    for(int i=1;i<11;i++)
    {
        a[i]=ans*i;
        ans=a[i];
    }
}

int A(int n,int m)
{
    return a[n]/a[n-m];
}

int C(int n,int m)
{
    return a[n]/a[m]/a[n-m];
}

int main()
{
    int num;
    init();
    scanf("%d",&T);
    while(T--)
    {
        getchar();  //这里接收回车
        scanf("%c %d %d",&c,&n,&m);
        if(c == 'A')
            num = A(n,m);
        else if(c == 'C')
            num = C(n,m);
        printf("%d\n",num);
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值