Hdu 1570 A C

A C

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3121    Accepted Submission(s): 2017


Problem Description
Are you excited when you see the title "AC" ? If the answer is YES , AC it ;

You must learn these two combination formulas in the school . If you have forgotten it , see the picture.




Now I will give you n and m , and your task is to calculate the answer .
 


 

Input
In the first line , there is a integer T indicates the number of test cases.
Then T cases follows in the T lines.
Each case contains a character 'A' or 'C', two integers represent n and m. (1<=n,m<=10)
 


 

Output
For each case , if the character is 'A' , calculate A(m,n),and if the character is 'C' , calculate C(m,n).
And print the answer in a single line.
 


 

Sample Input
  
  
2 A 10 10 C 4 2
 


 

Sample Output
  
  
3628800 6
 


 

因为最近在学动态规划,就偷懒了 采用一个捷径。

 

 

 

#include<iostream>
using namespace std;
int c[1000][1000];
int a[1000];
int aa(int m)
{
 if(a[m]) return a[m];
 if(m==1) return 1;
 return m*aa(m-1);
}
int cc(int m,int n)
{
 if(c[m][n]) return c[m][n];//如果计算过 则直接输出

 //状态转移方程 c(m,n)=c(m-1,n-1)+c(m-1,n)
 if(m==n || n==0)  return 1;
 if(n==1)  return m;
 return cc(m-1,n-1)+cc(m-1,n);
}

int main()
{
 int m,n,cas;
 char s;
 memset(c,0,sizeof(c));
 memset(a,0,sizeof(a));
 cin>>cas;
 while(cas--)
 {
  cin>>s>>m>>n ;
  if(s=='C')
   cout<<cc(m,n)<<endl;
  else
   cout<<cc(m,n)*aa(n)<<endl;


 }
}

 

 

 

 

 

 

 

 

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值