2月20日 Primitive Roots(原根)

原根和离散对数是密码学和数论的重要概念,本题如下(poj 1284):

Description


We say that integer x, 0 < x < p, is a primitive root modulo odd prime p if and only if the set { (xi mod p) | 1 <= i <= p-1 } is equal to { 1, ..., p-1 }. For example, the consecutive powers of 3 modulo 7 are 3, 2, 6, 4, 5, 1, and thus 3 is a primitive root modulo 7. 
Write a program which given any odd prime 3 <= p < 65536 outputs the number of primitive roots modulo p. 
Input


Each line of the input contains an odd prime numbers p. Input is terminated by the end-of-file seperator.
Output


For each p, print a single number that gives the number of primitive roots in a single line.
Sample Input


23
31
79
Sample Output


10
8
24

原根个数为phi(phi(n)),phi为欧拉函数,关于群、生成元的推导没有细看(后面会看),本题实际上还是一个欧拉函数打表,根据输入调出表中的值就行了。

#include<cstdio>
#define MAX 65537
int phi[MAX],notpri[MAX],pri[MAX];
void calphi()
{
	int cnt = 0;
	phi[1] = 1;
	for (int i = 2; i < MAX-1; i++)
	{
		if (!notpri[i])
		{
			phi[i] = i - 1;
			pri[cnt++] = i;
		}
		for (int j = 0; j < cnt; j++)
		{
			if (pri[j] * i > MAX)break;
			
				notpri[pri[j] * i] = 1;
				if (i%pri[j] == 0)
				{
					phi[i*pri[j]] = phi[i] * pri[j];
					break;
				}
				else
				{
					phi[i*pri[j]] = phi[i] * (pri[j] - 1);
				}		
		}
	}
}
int main()
{
	int n;
	calphi();
	while (scanf("%d", &n)!=EOF)
	{
		printf("%d\n", phi[phi[n]]);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

_viceversa

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值