[PAT A1065]A+B and C

[PAT A1065]A+B and C

题目描述

Given three integers A, B and C in [−2​63​​,2​63​​], you are supposed to tell whether A+B>C.

输入格式

The first line of the input gives the positive number of test cases, T (≤10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.

输出格式

For each test case, output in one line Case #X: true if A+B>C, or Case #X: false otherwise, where X is the case number (starting from 1).

输入样例

3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0

输出样例

Case #1: false
Case #2: true
Case #3: false

</font color=red>解析

题目很简单,就是输入A,B,C三个数,判断A+B是否大于C,由于这里数的范围有可能导致溢出,同号相加才会产生溢出,所以判断AB同号的情形,如果A,B都为正数,而A+B为负数了,说明溢出,同理可得负数的情况。

#include<iostream>
using namespace std;
int main()
{
 long long a, b, c;
 bool ans = false;
 int n;
 cin >> n;
 for (int i = 1; i <= n; i++)
 {
  cin >> a >> b >> c;
  long long temp = a + b;
  if (a > 0 && b > 0 && temp < 0) ans = true;
  else if (a < 0 && b < 0 && temp>=0) ans = false;
  else ans = (a + b > c);
  cout << "Case #" << i << ": " << boolalpha << ans << endl;
 }
 return 0;
}
水平有限,如果代码有任何问题或者有不明白的地方,欢迎在留言区评论;也欢迎各位提出宝贵的意见!
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值