[PAT B1034/A1088]Rational Arithmetic

[PAT B1034/A1088]Rational Arithmetic

本题是PAT乙级1034和甲级1088题,这里先放英文原题,要做乙级题的小伙伴们可以跳过直接看后面的中文原题

题目描述

1088 Rational Arithmetic (20 分)For two rational numbers, your task is to implement the basic arithmetics, that is, to calculate their sum, difference, product and quotient.

输入格式

Each input file contains one test case, which gives in one line the two rational numbers in the format a1/b1 a2/b2. The numerators and the denominators are all in the range of long int. If there is a negative sign, it must appear only in front of the numerator. The denominators are guaranteed to be non-zero numbers.

输出格式

For each test case, print in 4 lines the sum, difference, product and quotient of the two rational numbers, respectively. The format of each line is number1 operator number2 = result. Notice that all the rational numbers must be in their simplest form k a/b, where k is the integer part, and a/b is the simplest fraction part. If the number is negative, it must be included in a pair of parentheses. If the denominator in the division is zero, output Inf as the result. It is guaranteed that all the output integers are in the range of long int.

输入样例1

2/3 -4/2

输出样例1

2/3 + (-2) = (-1 1/3)
2/3 - (-2) = 2 2/3
2/3 * (-2) = (-1 1/3)
2/3 / (-2) = (-1/3)

输入样例2

5/3 0/6

输出样例2

1 2/3 + 0 = 1 2/3
1 2/3 - 0 = 1 2/3
1 2/3 * 0 = 0
1 2/3 / 0 = Inf

--------------------------中文原题---------------------------

题目描述

1034 有理数四则运算 (20 分)本题要求编写程序,计算 2 个有理数的和、差、积、商。

输入格式

输入在一行中按照 a1/b1 a2/b2 的格式给出两个分数形式的有理数,其中分子和分母全是整型范围内的整数,负号只可能出现在分子前,分母不为 0。

输出格式

分别在 4 行中按照 有理数1 运算符 有理数2 = 结果 的格式顺序输出 2 个有理数的和、差、积、商。注意输出的每个有理数必须是该有理数的最简形式 k a/b,其中 k 是整数部分,a/b 是最简分数部分;若为负数,则须加括号;若除法分母为 0,则输出 Inf。题目保证正确的输出中没有超过整型范围的整数。

解析

题目大意就是输入两个数,以上面的格式输出他们的和差积商,需要注意的地方就是如果分母为0,就输出Inf,详细解析可以移步至,里面有详细的注释
工欲善其事必先利其器——盘点PAT中非常好用的工具(持续更新)

#include<iostream>
using namespace std;
struct Fraction
{
 long long up, down;
};
long long gcd(long long a,long long b)
{
 return !b ? a : gcd(b, a%b);
}
Fraction reduction(Fraction f)
{
 if (f.down < 0) {
  f.up = -f.up;
  f.down = -f.down;
 }
 if (f.up == 0) f.down = 1;
 else {
  long long t = gcd(abs(f.up), abs(f.down));
  f.up /= t;
  f.down /= t;
 }
 return f;
}
Fraction add(Fraction a, Fraction b)
{
 Fraction f;
 f.up = a.up*b.down + a.down*b.up;
 f.down = a.down*b.down;
 return reduction(f);
}
Fraction difference(Fraction a, Fraction b)
{
 Fraction f;
 f.up = a.up*b.down - a.down*b.up;
 f.down = a.down*b.down;
 return reduction(f);
}
Fraction product(Fraction a, Fraction b)
{
 Fraction f;
 f.up = a.up*b.up;
 f.down = a.down*b.down;
 return reduction(f);
}
Fraction quotient(Fraction a, Fraction b)
{
 Fraction f;
 f.up = a.up*b.down;
 f.down = a.down*b.up;
 return reduction(f);
}
void show(Fraction f)
{
 if (f.down == 0) printf("Inf");
 else if (f.up < 0) {
  if (f.down == 1)printf("(%lld)", f.up);
  else if (abs(f.up) > f.down) printf("(%lld %lld/%lld)", f.up / f.down, abs(f.up) % f.down, f.down);
  else printf("(%lld/%lld)", f.up, f.down);
 }
 else {
  if (f.down == 1)printf("%lld", f.up);
  else if (abs(f.up) > f.down) printf("%lld %lld/%lld", f.up / f.down, abs(f.up) % f.down, f.down);
  else printf("%lld/%lld", f.up, f.down);
 }
}
int main()
{
 Fraction f1, f2;
 scanf("%lld/%lld %lld/%lld", &f1.up, &f1.down, &f2.up, &f2.down);
 f1=reduction(f1); f2=reduction(f2);
 show(f1); cout << " + "; show(f2); cout << " = "; show(add(f1, f2)); cout << endl;
 show(f1); cout << " - "; show(f2); cout << " = "; show(difference(f1, f2)); cout << endl;
 show(f1); cout << " * "; show(f2); cout << " = "; show(product(f1, f2)); cout << endl;
 show(f1); cout << " / "; show(f2); cout << " = "; show(quotient(f1, f2)); cout << endl;
 return 0;
}
水平有限,如果代码有任何问题或者有不明白的地方,欢迎在留言区评论;也欢迎各位提出宝贵的意见!
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
8.17 (Rational Numbers) Create a class called Rational for performing arithmetic with fractions. Write a program to test your class. Use integer variables to represent the private instance variables of the class the numerator and the denominator. Provide a constructor that enables an object of this class to be initialized when it is declared. The constructor should store the fraction in reduced form. The fraction 2/4 is equivalent to 1/2 and would be stored in the object as 1 in the numerator and 2 in the denominator. Provide a no-argument constructor with default values in case no initializers are provided. Provide public methods that perform each of the following operations: a. Add two Rational numbers: The result of the addition should be stored in reduced form. b. Subtract two Rational numbers: The result of the subtraction should be stored in reduced form. c. Multiply two Rational numbers: The result of the multiplication should be stored in reduced form. d. Divide two Rational numbers: The result of the division should be stored in reduced form. e. Print Rational numbers in the form a/b, where a is the numerator and b is the denominator. f. Print Rational numbers in floating-point format. (Consider providing formatting capabilities that enable the user of the class to specify the number of digits of precision to the right of the decimal point.) – 提示: – 有理数是有分子、分母以形式a/b表示的数,其中a是分子,b是分母。例如,1/3,3/4,10/4。 – 有理数的分母不能为0,分子却可以为0。每个整数a等价于有理数a/1。有理数用于分数的精确计算中。例如1/3=0.0000…,它不能使用数据类型double或float的浮点格式精确表示出来,为了得到准确结果,必须使用有理数。 – Java提供了整数和浮点数的数据类型,但是没有提供有理数的类型。 – 由于有理数与整数、浮点数有许多共同特征,并且Number类是数字包装的根类,因此,把有理数类Rational定义为Number类的一个子类是比较合适的。由于有理数是可比较的,那么Rational类也应该实现Comparable接口。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值