[PAT A1039]Course List for Student

[PAT A1039]Course List for Student

题目描述

Zhejiang University has 40000 students and provides 2500 courses. Now given the student name lists of all the courses, you are supposed to output the registered course list for each student who comes for a query.

输入格式

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤40,000), the number of students who look for their course lists, and K (≤2,500), the total number of courses. Then the student name lists are given for the courses (numbered from 1 to K) in the following format: for each course i, first the course index i and the number of registered students N​i​​ (≤200) are given in a line. Then in the next line, N​i​​ student names are given. A student name consists of 3 capital English letters plus a one-digit number. Finally the last line contains the N names of students who come for a query. All the names and numbers in a line are separated by a space.

输出格式

For each test case, print your results in N lines. Each line corresponds to one student, in the following format: first print the student's name, then the total number of registered courses of that student, and finally the indices of the courses in increasing order. The query results must be printed in the same order as input. All the data in a line must be separated by a space, with no extra space at the end of the line.

输入样例

11 5

4 7

BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1

1 4

ANN0 BOB5 JAY9 LOR6

2 7

ANN0 BOB5 FRA8 JAY9 JOE4 KAT3 LOR6

3 1

BOB5

5 9

AMY7 ANN0 BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1

ZOE1 ANN0 BOB5 JOE4 JAY9 FRA8 DON2 AMY7 KAT3 LOR6 NON9

输出样例

ZOE1 2 4 5

ANN0 3 1 2 5

BOB5 5 1 2 3 4 5

JOE4 1 2

JAY9 4 1 2 4 5

FRA8 3 2 4 5

DON2 2 4 5

AMY7 1 5

KAT3 3 2 4 5

LOR6 4 1 2 4 5

NON9 0

解析

  1. 题目的大致意思是首先输入N,K。N表示要查询的学生的人数,K表示课程数,接下来K行分别输入课程id和选这个课程的人数,再接下来输入选这个课程的人的姓名。姓名由四个字符组成,前三个字符是大写的英文字母,最后一个字符是数字。然后输入N个数据,表示要查询的学生的姓名。
  2. 输出的格式就是,对于每个要查询的学生,输出他的姓名,他选的课程数,并按升序输出他选的课程id
  3. 这道题目我一开始考虑的是使用map来做,使用map实现string和vector<int>之间的对应关系,但是提交上去的时候发现最后一组数据通过不了,只拿了23分。下面是我一开始的代码,最后一组数据显示运行超时。
  4. #include<iostream>
    #include<string>
    #include<vector>
    #include<map>
    #include<algorithm>
    using namespace std;
    int main()
    {
    	int n, k;
    	map<string, vector<int>> mp;
    	scanf("%d%d", &n, &k);
    	for (int i = 0; i < k; i++) {
    		int cnum, snum;
    		scanf("%d%d", &cnum, &snum);
    		for (int i = 0; i < snum; i++) {
    			string str;
    			cin >> str;
    			mp[str].push_back(cnum);
    		}
    	}
    	string query;
    	for (map<string, vector<int>>::iterator it=mp.begin(); it != mp.end(); it++) sort(it->second.begin(), it->second.end());
    	while (cin >> query) {
    		if (mp.find(query) != mp.end()) {
    			cout << query <<" "<< mp[query].size();
    			for (int i = 0; i < mp[query].size(); i++) cout << " " << mp[query][i];
    			cout << endl;
    		}
    		else {
    			cout << query << " " << 0 << endl;
    		}
    	}
    	return 0;
    }

     

  5. 后面我仔细阅读了晴神的代码,最后才得知是由于最后一组数据过于庞大,使用map实现string和vector<int>之间的映射会使得运算时间大大增加,所以他采用的办法是hash,这里为什么可以用hash呢?我想是由于学生的id是固定格式的,这一点在以后的做题过程中可以注意下,有这方面特征且数据量十分庞大的时候,很有可能就是需要使用hash来简化运算。这里我们使用hash就能直接使用vector而不用加map结构就可以解决掉问题了。注意这里的hash函数,举个例子,ABC0那就是(A-'A')*26*26*26+(B-'A')*26*26+(C-'A')*26+0=26*26+26=702.(经评论区@旱地摸鱼(^・ェ・^)  提醒,ABC0应该是(A-'A')*26*26*10+(B-'A')*26*10+(C-'A')*10+(0-‘0’)=26*10+2*10=280,这里感谢指正
  6. #include<iostream>
    #include<vector>
    #include<algorithm>
    using namespace std;
    #define maxn 26*26*26*10+1 //定义数组的最大长度
    int getID(char name[]) //获取ID的函数
    {
    	int id = 0;
    	for (int i = 0; i < 3; i++) id = id * 26 + name[i] - 'A';
    	id = id * 10 + name[3] - '0';
    	return id;
    }
    vector<int> v[maxn];
    int main()
    {
    	int n, k;
    	char name[4];
    	scanf("%d%d", &n, &k);
    	for (int i = 0; i < k; i++) {
    		int cnum, snum;
    		scanf("%d%d", &cnum, &snum);
    		for (int i = 0; i < snum; i++) {
    			scanf("%s", name);
    			v[getID(name)].push_back(cnum); //对于每个输入的name对应位置vector就push该课程号
    		}
    	}
    	for (int i = 0; i < maxn; i++) {
    		if (!v[i].empty()) sort(v[i].begin(), v[i].end()); //使用sort函数排序
    	}
    	for (int i = 0; i < n; i++) { //查找
    		scanf("%s", name);
    		if (!v[getID(name)].empty()) {
    			int len = v[getID(name)].size();
    			printf("%s %d", name, len);
    			for (int i = 0; i < len; i++) printf(" %d", v[getID(name)][i]);
    			printf("\n");
    		}
    		else {
    			printf("%s 0\n", name);
    		}
    	}
    	return 0;
    }

     

评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值