PAT 1146 Topological Order (25 分) 拓扑验证

16 篇文章 0 订阅
15 篇文章 0 订阅

Sample Input:

6 8
1 2
1 3
5 2
5 4
2 3
2 6
3 4
6 4
5
1 5 2 3 6 4
5 1 2 6 3 4
5 1 2 3 6 4
5 2 1 6 3 4
1 2 3 4 5 6

Sample Output:

3 4
#include<iostream>
#include<string>
#include<sstream>
#include<vector>
#include<algorithm>
#include<cmath>
#include<map>
#include<queue>
using namespace std;

//12:55 

int main()
{
	//freopen("C:\\Users\\chenzhuo\\Desktop\\in.txt", "r", stdin);
	int m,n;
	cin >> n >> m;
	vector<vector<int> > node(n + 1);
	vector<int> fron(n + 1,0);//前驱结点
	for (int i = 1;i <= m;i++){//建表
		int k1;cin >> k1;
		int k2;cin >> k2;
		node[k1].push_back(k2);
		fron[k2]++;//前驱加1
	}

	int num;
	cin >> num;
	int isf = 1;
	for (int i = 0;i < num;i++)
	{
		vector<int> fron1(fron);//拷贝前驱表
		vector<int>tmp(n);
		int key;
		for (int a = 0;a < n;a++){
			cin >> tmp[a];
		}
		int flag = 1;
		for (auto k : tmp) {
			if (fron1[k] > 0) {//还有前驱存在
				flag = 0;
				break;
			}
			for (auto j : node[k]) {
				fron1[j]--;
			}
		}
		if (!flag) {
			if (isf) {
				isf = 0;//现在开始不是第一个出现了
			}
			else cout <<" ";
			cout <<i;
		}

			
	}




}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值