1117. Eddington Number(25)

1117. Eddington Number(25)

时间限制
250 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

British astronomer Eddington liked to ride a bike. It is said that in order to show off his skill, he has even defined an "Eddington number", E -- that is, the maximum integer E such that it is for E days that one rides more than E miles. Eddington's own E was 87.

Now given everyday's distances that one rides for N days, you are supposed to find the corresponding E (<=N).

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N(<=105), the days of continuous riding. Then N non-negative integers are given in the next line, being the riding distances of everyday.

Output Specification:

For each case, print in a line the Eddington number for these N days.

Sample Input:
10
6 7 6 9 3 10 8 2 7 8
Sample Output:
6
题意:设e为在n个数中,有不少于e个数的值大于e。在给定n个数中,求最大的e

分析:一开始以为是什么最大下降子序列的问题,发愣了很久。然后忽然发现排序一下,倒着数直接就出来了……

代码:

#include<iostream>
#include<set>
using namespace std;
multiset<int> num;
int m=0;
int main()
{
	int n,tmp,cnt=0;
	cin>>n;
	for (int i=0; i<n; i++)
	{
		cin>>tmp;
		num.insert(tmp);
	}
	set<int>::iterator it=num.end();
	while(1)
	{
		it--;
		if(*it > cnt + 1) cnt++; 
		if(it == num.begin()) break;
	}
	cout<<cnt;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值